Sign in with
Sign up | Sign in
Your question
Solved

Software to format a write protected hard disk

Tags:
  • Hard Drives
  • Storage
Last response: in Storage
Share
September 25, 2012 8:20:11 PM

I am fed up of my external ard disk, i.e. Western Digital Elements 1023 2 TB. Till yesterday it was working fine, but all of the sudden yesterday when I connected it to my laptop Windows 7, an error popped up. It is not being read in "My computer". I even tried the disk management thing i.e. tried to initialize it, but it said that the disk is write protected. Neither can I format it as it is write protected nor can I use it. Can anyone help me please.

More about : software format write protected hard disk

Best solution

a c 104 G Storage
September 26, 2012 12:20:41 AM

Hello,

Is the external WD 2 TB drive seen in Disk Management, as say Disk 1 or 2, Basic 2T, Online? And is the Volume Info area does it say NTFS, or possibly RAW or Unallocated?

If it is recognized properly, then you can clear the "Read Only" flag.

Go to Accessories, then right click on Cmd Prompt to runAs Administrator.
There type "Diskpart"
Type "list Disk", & you will see a list of the disks on your computer. Choose carefully this 2TB disk, by the Disk #.
Then type "Select Disk #" (whatever the number of the disk is)

Then type "Attributes disk clear readonly".

Hopefully that will make it possible for you to read and write to the disk.

That hasn't explained why the change in Disk character. Could have been from unplugging it without using the Safely remove Disk, or possibly even a virus.

Share
September 26, 2012 9:15:48 AM

@John _VanKirk The disk is being shown in "Disk Management" & its status is "unallocated"...I tried to initialize it but its write protected. I have even tried the method that you suggested but it failed saying that the disk cannot clear the attributes. Still the same problem comes up. Also tried that method of editing the registry and assigning the "0" value but all in vain. Even dunno how to recover data from the drive. Huh.
m
0
l
Related resources
a c 104 G Storage
September 26, 2012 6:35:58 PM

Hi Arshia,


Are you trying to just reset the HDD, as would happen with "Initialize" as you tried, or are you trying to recover data from it?

To attempt to recover the lost partitions, download a partition manager program, Like EaseUS Partition Master. Here is the website.

www.partition-tool.com/personal.htm

Install it and go to the main menu. There is a user manual to read. Might try the recover partition wizard, to see if it can restore your prior partitions and included data.

If you are trying to reclaim the HDD to use like new, you can download and run the WD Lifeguard tools for Windows, and reset to factory conditions. Here is their website:

http://support.wdc.com/product/download.asp?groupid=606...
m
0
l
less than a minute ago

Hi John,

I have the same problem. I tried to recover the lost partition using the partition tool but as I go along the process I could not see the partition in order for the program to proceed. Any more ideas that I could try to recover my data.

Thank you in advance
m
0
l
!