Sign in with
Sign up | Sign in
Your question
Closed

Excel Not using all 8GB RAM

Last response: in Components
Share
September 20, 2010 1:27:38 PM

Hello,
I am using a Lenovo Thinkpad T410 . OS = Win 7 64 bit. Office 2010 64 bit (Trial), Inel Core i5 (vpro) processor. I recently upgraded my RAM to 8 GB. The main reason of switching to a 8 GB ram was to get more processing power for my excel spreadsheets. When i run my excel filed the CPU utilization touches 100% but the system only uses ~ 2 GB gb of ram and the remaining 6 gb os ram is left untouched. Is there a way that I can use the 6 gb ram to speed-up my excel files?

Any help on this will be much appreciated.
Thanks,
Ravi

More about : excel 8gb ram

September 20, 2010 1:51:00 PM

Hi ravisolanki79 and welcome to Tom's hardware forum.

I think that the problem is the 64 bit trial even that with a full version 32 or 64 bit Excel or Word will never use 8GB RAM only heavy applications at the same time like Adobe or Autocad can use that amount of RAM.
Score
0
September 20, 2010 2:26:04 PM

If your CPU is running at 100%, that is most likely the bottleneck, not the amount of RAM. Remember that programs only use as much RAM as they need, so in your case it seems the extra memory is not required.
Score
0
Related resources
September 20, 2010 3:47:09 PM

Herr_Koos said:
If your CPU is running at 100%, that is most likely the bottleneck, not the amount of RAM. Remember that programs only use as much RAM as they need, so in your case it seems the extra memory is not required.


This should explain everything.. Adding extra RAM is not going to increase processing speed.. It only smoothens out the application experience provided the application can make efficient use of it..
Score
0
September 20, 2010 10:50:16 PM

Many thanks for the response so far and let me ask 2 additional questions.
1) CPU - Buying a new machine is not an option now. Can I buy some external hardware and plug into my existing machine using a USB port? At this point I cannot invest more in buying a new machine.
2) I now get the point that excel is using the RAM it should be using but is there a way to override it and force excel to use say 5 GB of RAM ? I came across certain articles where the software developers have given tweaks to use more than “normal” RAM for faster processing for “their specific programs”.
Thanks,
Ravi
Score
0

Best solution

September 20, 2010 11:40:34 PM

Judging by your 2Gb comment, You must be running the 32bit version of excel. AS I understand it, 64 bit office contains both because the 64bit version is less compatible with previous 32bit addins and so the 32 bit is installed by default.

You might want to go back thru the install and try out the 64bit version of excel which does not have the 2GB addressing limitiation thou you may have to redo your spreadsheets(s)
Share
September 21, 2010 8:42:06 AM

popatim said:
Judging by your 2Gb comment, You must be running the 32bit version of excel. AS I understand it, 64 bit office contains both because the 64bit version is less compatible with previous 32bit addins and so the 32 bit is installed by default.

You might want to go back thru the install and try out the 64bit version of excel which does not have the 2GB addressing limitiation thou you may have to redo your spreadsheets(s)



Hi - If I am understanding your comments correctly than you are trying to say is that i am running a file which was originated on 32 bit of excel and currently being run on 64 bit of processor. If yes, then this is exactly what I am doing.

I will try to create a new file from scratch on 64 bit excel and hope it works fine.

Thanks,
Ravi
Score
0
September 21, 2010 1:18:15 PM

Best answer selected by ravisolanki79.
Score
0
September 21, 2010 1:19:39 PM

popatim said:
Judging by your 2Gb comment, You must be running the 32bit version of excel. AS I understand it, 64 bit office contains both because the 64bit version is less compatible with previous 32bit addins and so the 32 bit is installed by default.

You might want to go back thru the install and try out the 64bit version of excel which does not have the 2GB addressing limitiation thou you may have to redo your spreadsheets(s)



Hi - I copy pasted the data in a "Fresh" file. Fresh file was originated from Excel 64 bit and it went through super fast... thanks for all the help.
Score
0
September 24, 2010 1:43:21 AM

I'm glad you got it sorted out. That must be one huge spreadsheet. LoL.
Score
0
September 24, 2010 2:15:04 AM

This topic has been closed by Mousemonkey
Score
0
!