Sign in with
Sign up | Sign in
Your question

9800 gx2 broke? what to get now?

Last response: in Graphics & Displays
Share
June 11, 2010 11:59:27 PM

Hey guys, I have a 9800gx2 vid card and I think it is broken:( . I was installing a new harddrive and it went fine... the Harddrive showed up and everything. I was just using it for extra storage and was not making it my primary drive. I then restarted my computer and it would not boot up. The computer turned on but it would just have a black screen. I thought it might be something I did when installing Harddrive, so I checked all connections and it still wouldnt work. I then took the new hard drive out and it still wouldnt work.

It started to boot up to windows and have a display every 10 times or so that I would try. One time when it booted up the video on the screen looked scrambled. I tested to see if the ram was the issue and it wasnt.

I then thought the graphics card might be broken and I decided to put a different graphics card in. The system booted up fine when I did this.

Any Idea what happened.

My system
Abit IP350 Pro ATX Motherboard 1 pci-e 16x and one 8x
Antec case
Intel q6600 oc'd to 3.6
OCZ 1000w power supply
8gigs of OCZ ram
Samsung 7200rpm 250gb
new hd is Seagate 7200rpm 500gb
and the 9800gx2

If the card is broken I also am wondering what kind will equal the quality or be better for a decent price. I will spend whatever I need to get the performance of my old card but I want to keep it as cheep as possible. I was looking at buying from newegg or bestbuy.

Thanks for your help in advance

More about : 9800 gx2 broke

June 12, 2010 1:09:58 AM

Mine broke last week i sent it back and got a GTX 285 check ur warranty :D 
m
0
l
Related resources
June 12, 2010 3:04:08 AM

The problem is that the card is not from any company like pny bfg evga etc. It is a card that came out of a alienware or xps im guessing and I dont have the computer it came out of so no go on warrenty:(  That is what I was told today. The weird thing is that the video card works, im using it right now, It just wont work after I shut it down and try to restart. It will work again if i wait like 30 min to turn it on again. HELP!!!!

I took a picture of part of the card. The 2 different plug ins for power, im guessing, I noticed that one of the pins is a different color. is this a problem and can it be fixed????




and these are the cards i had in mind

http://www.bestbuy.com/site/PNY+-+NVIDIA+GeForce+GTX+47...

http://www.bestbuy.com/site/VisionTek+-+ATI+Radeon+HD+5...

http://www.bestbuy.com/site/Sapphire+-+ATI+Radeon+HD+58...

would this one perform as good as gx2?
http://www.bestbuy.com/site/Sapphire+-+ATI+Radeon+5770+...


and is my mobo able to do sli or crossfire? Ive gotten mixed answers on forums about this because of the pci-e being x16 and other being x8.
m
0
l
June 12, 2010 3:12:03 AM

Wowgamer said:
The problem is that the card is not from any company like pny bfg evga etc. It is a card that came out of a alienware or xps im guessing and I dont have the computer it came out of so no go on warrenty:(  That is what I was told today. The weird thing is that the video card works, im using it right now, It just wont work after I shut it down and try to restart. It will work again if i wait like 30 min to turn it on again. HELP!!!!

I took a picture of part of the card. The 2 different plug ins for power, im guessing, I noticed that one of the pins is a different color. is this a problem and can it be fixed????
http://i969.photobucket.com/albums/ae174/06wrxsnowboarder/IMG00172-20100611-1925.jpg



and these are the cards i had in mind

http://www.bestbuy.com/site/PNY+-+NVIDIA+GeForce+GTX+47...

http://www.bestbuy.com/site/VisionTek+-+ATI+Radeon+HD+5...

http://www.bestbuy.com/site/Sapphire+-+ATI+Radeon+HD+58...

would this one perform as good as gx2?
http://www.bestbuy.com/site/Sapphire+-+ATI+Radeon+5770+...


and is my mobo able to do sli or crossfire? Ive gotten mixed answers on forums about this because of the pci-e being x16 and other being x8.



Buy this one
http://www.amazon.com/XFX-Radeon-5870-GDDR5-HDMI/dp/B00...

If you dont have the cash yet, dont go with some mid level cards, save the money and buy one of the best graphics cards on the market
m
0
l
June 12, 2010 3:17:46 AM

Ok thanks! Its cheaper at Bestbuy fyi. But is my card broken or no?
m
0
l
June 12, 2010 4:06:44 AM

Awesome Thanks! im still probably going to go for the lower end one with the nvidia because of it being a little cheaper unless their is something wrong with it. I contacted dell and they say im out of luck unless I have the S/N of computer...:( 
m
0
l
a b U Graphics card
June 12, 2010 12:25:52 PM

open her up and look
m
0
l
June 12, 2010 1:10:11 PM

I had a 9800GX2 that broke as well, and I replaced it with a GTX 275, which was fairly new at the time. In my opinion the gtx275 is a better card than the GX2, more consistent FPS and smoother gameplay. More reliable too, I have demolished the poor thing with intensive games and its still going great.

In the present situation ATI is the way to go. A 4890 is a nice card, but a 5850 is what I'd recommend. I can't put my finger on it, but there's something about the 5830 I don't like, seems too cut down for an 58xx series card to me.
m
0
l
June 12, 2010 3:59:15 PM

I had it opened up and didnt notice anything. There were a bit of dust collected in it but other than that I did not notice anything. Does that pin that is a different color in the picture not make a difference.
m
0
l
June 12, 2010 6:08:32 PM

So i have restarted the computer and everything is still working..... No clue why. My next question is should I try putting the second hard drive back in??????
m
0
l
a c 1406 U Graphics card
June 12, 2010 6:31:55 PM

Dust can be a source of instability since it hinders airflow and reduces cooling.
I don't think the color of the pin changes anything unless it would be obviously burnt.
Go on try the drive.
m
0
l
June 12, 2010 7:16:35 PM

Ok. is there any reason why I should not clone the new drive to be my primary??? any problems with doing this. And once it is done do I need to switch around were the drives are plugged in???
m
0
l
!