Sign in with
Sign up | Sign in
Your question

IMac disconnects from hardwired network 2010

Last response: in CPUs
Share
September 21, 2010 11:56:05 PM

New out of the box Imacs Intel-based running OSX 10.6 - two of them have the same issue.

A working network that is 6 years old - inhouse using Cisco switches on a Cox Business Cable system with 10 other Macs working fine. All of the other Macs - laptop or desktop are running 10.5.8 - these are the first two Snow Leopard Macs to install.

We connect them hardwire to the network and they work fine - acquire an IP, mount the Xserver, browse to the internet. All is good. 5 minutes later they disconnect from the network. Everything looks like it's running but all network traffic is off. Server dismounts after a few minutes and browser stops.

Go to the network panel and renew leases on DHCP and it starts working again.

DHCP service is inhouse on the Xserve and it shows an active lease on these iMacs.

Connect them via in-house Airport and they work continuously via WIFI no problems - only the hardwire connection is interrupting.

Inhouse network is running all the same Ciscos at 100mb. Cox Network is running nominally at 10-20mbytes.

Settings in the two network panels are the same - DHCP, everything else default. No VPN.

Theories we're working:

1. Signal strength on the network combined with over-sensitivity at the new iMac - clearly it can support wireless so the basics are working on both and the problem is hardwire related.

2. Cisco/iMac interaction - SD216 and SR224 are non-programmable switches but perhaps we're seeing something new that isn't being handled the same by Snow Leopard or the hardware interface in the iMac vs. 802.3 implementation.

Appreciate any other theories we can pursue?
a c 149 à CPUs
September 22, 2010 1:27:16 AM

Try:
copying the DNS Servers from the Wireless connection - found under System Preferences>Network>Location:Wireless Network - Show:Airport,

and applied them to the DNS servers on Location: Internet Connection - Show: Built-In Ethernet.

m
0
l
September 22, 2010 9:26:29 PM

A couple of updates - thanks for the suggestions.

- checked the DNS IPs from Airport units and these are the same as provided by DHCP to each workstation, but went ahead and plugged them in manually to see if that made a difference but it did not.

- isolated that this problem shows up on all Intel-based Macs whether running 10.6 or 10.5.8 and we have four units on the network - all disconnect after 10-30 minutes of use.

- disconnect behavior is strange - network preference looks like we're still connected. we can ping across the network so we're still connected but we don't have DNS service so browser and email don't work. remember wireless connection doesn't have this problem on same computer and all other computers on the network are working fine hardwire or WIFI. problem only shows up on hardwire connections and Intel Macs.

- restarted all switches and server - an network modem that goes out over Cox to Ethernet connection via Cox

- server is an Xserve running 10.5.8 and DHCP is providing a range of protected IP numbers. DHCP seems to be working fine for all other Macs. No PCs on network.
m
0
l
Related resources
a c 149 à CPUs
September 23, 2010 1:52:01 AM

Have you turned off IPv6?
As for the DNS, Try setting your DNS servers to OpenDNS (208.67.222.222 and 208.67.220.220) and see what you get.
m
0
l
September 25, 2010 12:21:59 AM

OK here is an update.

We did make sure that IPV6 was turned off. it was.
We did try these IP numbers but that did not change anything.
Used Namebench to look at name servers and it turns out the Cox Cable DNS service is the fastest around.

Remembering that this problem only shows up on Intel-based Macs running 10.5.8 up to 10.6 and shows up a a dropped DNS where we can still ping the network successfully. The DHCP service is from an inhouse xserver running 10.5.8 and the DNS service is external from Cox.

We also setup a "static" or fixed IP on the Mac server and manually setup each Mac with the static IP to see if this would change the problem.

At this point the problem appears to be gone. Monday we plan to go back to DHCP and see if our problem is still there. If not, I'm going to guess outside causes - maybe DNS dropping out intermittently or something along those lines - something that Intel Macs are more sensitive to perhaps?

I don't feel this is solved but until symptoms come back we're at a stand still.

Thanks for the insight. More later.
m
0
l
October 2, 2010 1:05:02 AM

Sorry - all of the answers on this problem helped us to eliminate things but the final solution was none of the above. And we don't have answers for why the problem showed up the way it did. For instance, why did this only show up on Intel-based Macs? it showed up on a 2-year-old MacBookPro and 2 new out of the box Imacs. But not on any of the older non-intel-based processors.

There was a conflicting IP number on the network - a static IP had been set on the Xserver for a printer, and somehow DHCP had granted a lease for the same IP to one of the new Imacs. We setup fixed IPs for all the Intel-based processors and let the dynamic DHCP grant time out and the problem resolved itself.

How did the Xserve grant an IP number that was set as a static IP for a printer? We can't answer that one. But clearly once it happened, the network was conflicted and Intel-based Macs were getting thrown off/disconnected frequently.

We tried to recreate the situation but we could not get the DHCP server to grant a duplicate IP to a static IP again.

Thanks again everyone for providing ideas that helps us eliminate all the obvious.

BTW - Cox Cable turns out to be consistently the fastest turnaround DNS service we could find anywhere.
m
0
l
!