Sign in with
Sign up | Sign in
Your question

Catalyst Control Center not appearing on the list of installable items

Last response: in Graphics & Displays
Share
June 12, 2010 9:33:53 PM

If this has already been answered in the direct fashion im looking for I must apologize in advance for not searching, im so frustrated right now i just want a clear answer on what to do.

Here is the issue...no matter what I try (uninstalling everything related to ATI in safe mode, rolling back to an earlier version, defragging the hard drive, downloading the dedicated CCC package vs the Suite) nothing has worked for me so far. I recently purchased a new sceptre 27" monitor which is great except for the black border around the screen due to ATI under scan and over scan settings. I know that I need to configure the monitor which is fine except when I did that it all I saw was a screen that had a couple of options like, look for new drivers, contact ATI ect... So I read that someone with a similar issue fixed it by uninstalling his CCC and reinstalling it. I attempted to do this however upon installation all I see when choosing custom install is the ATI install manager, C++ redistributable, LOTR Free trial and something else, no where is there an option to check Catalyst Control Center. This issue followed me from version 10.5-10.1 all with the same result. My last working version was 10.2

System Specs:

Core 2 Duo 2.8 Ghtz
4gb Ram
ATI 4650 1gb

All on a Toshiba satellite P500-12D 18.4"

Please im begging the community to help me here, i just want to enjoy my new monitor.

More about : catalyst control center appearing list installable items

June 13, 2010 12:44:48 AM

already did that multiple times...also did Revo Uninstaler Pro and cleared everything out and reinstalled it.
m
0
l
Related resources
June 13, 2010 2:57:14 AM

What OS?
Did you install the correct driver for your 4650?
Did you try with the driver inside the CD?
m
0
l
June 13, 2010 2:59:33 PM

Its Windows 7 64 Bit and yes I found a site with drivers specificly for the 4650 and the same issue occured. Also because it is a laptop it did not come with a CD.

As of now I am installing each part of the CCC individually from the C:\ATI\Support\10-5_vista64_win7_64_dd_ccc_enu\Packages\Apps\CCC

I now have CCC appearing on my start menu Items but I am missing CCC-Basic,CCC-Advanced and CCC-Wizard I do have CCC and Restart Runtime.

With everything manually installed when I click several different application icons I get the blue circle and then nothing happens. The problem is I dont know what an actual install directory looks like, so I dont know where to put cirtain folders or files, let alone what to name them. If someone could post a screenshot of their Program Files(x86)\ATI Technologies\ATI.ACE folder it would be much appriciated.
m
0
l
Anonymous
June 13, 2010 8:02:58 PM

I'm having an identical issue and have taken identical steps.
Updating from 10.3 to 10.5 with a uninstall/Driver sweep between.
Cannot get Catalyst Control Cent(re|er) to install, uninstall or even appear in the ATI Install manager.
I hope there is a standalone release of the control centre, as I currently am unable to rotate my monitors without it :\.
m
0
l
June 13, 2010 10:36:33 PM

I downloaded the mobility drivers and it worked flawlessly. I knew about them before but could not find them via toshiba. Luckily someone posted a link to the 10.5 ones and it worked just fine. So to anyone using a laptop us the MOBILITY drivers.
m
0
l
!