Sign in with
Sign up | Sign in
Your question

Powercolor 5870 PCS+ flickering/freezing issue

Last response: in Graphics & Displays
Share
June 13, 2010 10:29:55 AM

Hello,
I'm currently having problems with my Powercolor 5870 PCS+ which I recently purchased, 1-2 months ago.

The problem I'm having is that every now and then when gaming, the screen starts flickering, and after a while the flickering results in a freeze. Sometimes it freezes when no flickering has ocurred.

I don't belive this is an overheating issue, since I checked the temperatures once when flickering started, and they were only around ~50 degrees, which is quite low I suppose.

The freezes usually occur after about 30-1 hour of gaming sometimes I can play for longer. I've tried uninstalling all drivers and stuff with the ati catalyst install manager and inserting the cd that came with the card and installed the drivers on it, but this has not worked. Should I maybe try underclocking it to 850/1200, the normal clocks for 5870's? It's at 875/1225 at the moment, but I dont see how underclocking would help when it doesn't even get that hot, maybe there's some problem with voltages?

Specs: Amd Phenom II 945 x4 3GHz
GIGABYTE GA-MA770T-UD3P
Powercolor 5870 PCS+ 875/1225
4GB Crucial DDR3 1333MHz
Corsair Powersupply 650W
Western Digital Caviar 1TB
June 13, 2010 10:36:38 AM

Hello and welcome to the forums :) 
Well do a clean uninstall of your driver and then install the latest drivers from AMD's site
Here is how to do a clean install:
1_Download and install "Driver sweeper" from Guru3d.com and install
2_Go to add/remove programs and uninstall the driver and reboot
3_Boot to safe mode and open driver sweeper,then click on ATI and then click on clean
4_Reboot and boot normally to windows and install the new drivers after that you need to restart,and its done

June 13, 2010 11:47:54 AM

How do you boot in safe mode? I'm a noob :) 
Related resources
June 13, 2010 1:20:27 PM

Open Run and type "msconfig" and press enter.Then open "boot" tab and choose "Safe bood" and restart,then next time your computer should boot up in safe mode.
Remember to to uncheck this option when you finished your tasks in safe mode.
June 13, 2010 4:49:12 PM

Hmm, it might be good now. Haven't been able to play that much today but I was on for a few hours on World of Warcraft before and no problems. Thanks alot for the help, whether it's gonna work or not.
June 13, 2010 5:08:23 PM

You are welcome,i hope it will work fine
!