Sign in with
Sign up | Sign in
Your question

Floppy Diskette not enabled in BIOS?

Last response: in Motherboards
Share
May 6, 2011 8:36:53 AM

Hi all,
New here (and somehow the thread I started yesterday has gone missing)...

Acer Aspire Laptop 1350 with 3 1/2 Floppy Drive (14 years old). Problem I have is that, for the past 6 years or so I've not used the Floppy Drive, but when I needed to a couple of days ago it did not access, register a disc or does not appear in My Computer...
After entring BIOS on the first screen (INFO) it states Diskette A 'disabled' but does not allow me to enable it?!

All I have ever done on my Laptop is format the drive once a year using the System Restor recovery discs that came with it (to return it to factory finish) and I've nere touched the BIOS before so how can the Floppy now be disabled when I've not touched anything?

I've tried uninstalling the driver and rebooting but still does not recognise it.

How do i get BIOS to re-enable the Floppy Drive if it won't let me change anything in it?

Any help please?

Dave
a b V Motherboard
May 6, 2011 10:52:29 AM

Maybe this helps (it's old)
"Disabling Floppy Controller in Device Manager Also Disables Controller in BIOS"
http://support.microsoft.com/kb/217071

Right click on the My Computer icon go to Device Manager (or Control Panel/Administrative Tools/Computer management/device manager), look for "floppy disk controllers" and "floppy disk drives" and right click on both, set to enable.

May 6, 2011 11:01:31 AM

mosox said:
Maybe this helps (it's old)
"Disabling Floppy Controller in Device Manager Also Disables Controller in BIOS"
http://support.microsoft.com/kb/217071

Right click on the My Computer icon go to Device Manager (or Control Panel/Administrative Tools/Computer management/device manager), look for "floppy disk controllers" and "floppy disk drives" and right click on both, set to enable.



Hi there,
I've tried this (the first thing i did) and it is showing as enabled in Device Manager but not registering in windows, My Computer, etc. Even if I put a disk in it does to access it.
Related resources
a b V Motherboard
May 6, 2011 6:57:33 PM

Look for a floppy controller in the BIOS, probably it's in the peripherals section. Enable that and try again enabling the floppy.
May 7, 2011 8:37:14 AM

mosox said:
Look for a floppy controller in the BIOS, probably it's in the peripherals section. Enable that and try again enabling the floppy.


Hi,
The BIOS is very basic to say the least!

First screen is the INFO - where you can't access any section, it only tells you what's what. This is where it states the Diskette A is disabled. Actually this is the only screen which mentions the Floppy A drive!

Second screen is MAIN where it allows date, time and a couple of other things.

Third screen i can't remember as of this moment (but it has nothing to do with Floppy...

Fourth screen is SECURITY which allows for setting passwords, etc.

Fifth screen is BOOT where it allows for selecting which device boots up (HDD, CD/DVD, Removables USB, etc. and IDE or something) nothing states 3 1/2 Floppy Drive.

Sixth screen is EXIT.

I have contacted Acer but as yet they've not replied...

What I don't understand is how it could have disabled itself as I did not do it.
August 7, 2011 2:56:46 PM

mosox said:
Look for a floppy controller in the BIOS, probably it's in the peripherals section. Enable that and try again enabling the floppy.

I'm having the same problem and I found the floppy configuration in my BIOs and its asking me what size is my floppy device , I look at the box of diskettes and saw 144 x 3.5 does this sound right to you .
!