Sign in with
Sign up | Sign in
Your question

Help -- 3d games stutter/skip frames very frequently

Last response: in Graphics & Displays
Share
June 15, 2010 12:53:21 AM

Hi,

The following is my specs:
AMD Athlon II x4 620 @2.6Ghz
4gb (3.2gb) DDR2-800
Windows 7 x32
ATi Radeon HD 5770

The problem is my computer starts skipping frames after a short time after playing 3d games. The frame skips are very frequent and cause games to become unplayable. My computer is not overheating even though the symptoms make it seem like that is the problem.
Some games do not frame skip at all.

The frame skips last from 1/4th of a second to half a second. They occur every one to five seconds. Aiming is pretty much impossible in any games.
I call them stutters/frame skips because I don't know what their "Official" name is. They're basically short pauses.
It drives me NUTS!
The 3d games I have been playing that are affected are (All of which my computer should play fine. Also, all of which are my favorite games.):
Call of Duty: Modern Warfare 2
Grand Theft Auto 4
Red Faction: Guerrilla

The 3d games I have been playing that are not affected are:
Quake III Engine Games
Fallout 3
Half Life 2 and other source-engine games
Doom 3 (Which is strange because MW2 uses the same engine)
Bioshock
Dirt 2

I have tried checking my temperatures when the game is running. All of them are normal and my case is very well vented.

Please help.
a c 189 U Graphics card
June 15, 2010 8:21:35 AM

Some people also got the same issue with MW2 (even with higher system), so i guess the problem is the game itself...
For GTA4, this game is poorly coded game, no surprises it has many lags...

Since the rest of your games are fine then don't worry about that. I think your problem is the game itself.
Did you updating your driver with the latest one?
m
0
l
June 15, 2010 5:44:01 PM

What resolution are you playing at? I was thinking it may be a heat issue, but if some of your games are running fine, heat is prob. a good issue to rule out. Try updating your drivers by completely removing your old ones then installing the latest. See how that works out.
m
0
l
Related resources
June 15, 2010 10:44:47 PM

wa1 said:
Some people also got the same issue with MW2 (even with higher system), so i guess the problem is the game itself...
For GTA4, this game is poorly coded game, no surprises it has many lags...

Since the rest of your games are fine then don't worry about that. I think your problem is the game itself.
Did you updating your driver with the latest one?


Sorry, I forgot to mention the timeframe.
This problem has been happening since early may. However, MW2, GTA IV and Red Faction Guerrilla all used to run flawlessly.
It is very strange.
I already tried downgrading my drivers and re-upgrading them. It's not a driver issue.

Quote:
What resolution are you playing at?


All of my games are running at 1440 x 900 because that is what my monitor supports.
m
0
l
June 15, 2010 11:17:22 PM

Are you using a sound card or anything like that? I'm wondering if your sound is not playing nicely with graphics drivers? Maybe look into updated sound drivers or something.
m
0
l
a c 189 U Graphics card
June 16, 2010 1:53:08 AM

Hmm, have you try re-install the game?

Add any components in your system?
m
0
l
!