Gigabyte GA-X58A-UD3R running SATA HDD in IDE mode?

Hi everyone! I really need some help and would appreciate any advice that the knowledgeable people of this forum would be kind enough to provide.

I built a new gaming PC for myself a few weeks ago using a Gigabyte GA-X58A-UD3R motherboard and a Western Digital Caviar Black SATA hard drive (WD1002FAEX). It was my first time building a PC in many years and I had difficulty getting my BIOS to detect the hard drive in the beginning (due to my own error), so I set it to IDE mode "temporarily" while I was troubleshooting the issue.

Unfortunately, I forgot to switch the drive back to AHCI once I had everything working. I now have Windows 7 installed along with all of my games, programs, and data from my old PC. I didn't realize the mistake I made until I went into my BIOS this morning and saw that the drive was still set to IDE.

As I understand it, I'm taking a big hit in performance by running the drive in IDE, instead of AHCI. Would I need to reformat my drive and re-install everything in order to run it in AHCI? Would there be a more efficient way of accomplishing this without starting over from scratch, so to speak?

Thank you for your time -- I'm sorry for the long/clueless post!
6 answers Last reply
More about gigabyte x58a ud3r running sata mode
  1. Bump, I'm having the same problem.
  2. Thank you for bumping this. =) It is reassuring to know that I am not the only person who made this error or is encountering this issue.

    I attempted setting my drive from IDE to AHCI this morning, but Windows wouldn't start when I did it.

    I also noticed that only IDE and AHCI are options in my BIOS -- not "SATA", if that should be an option.
  3. Bump. =(
  4. i am also having the exact same problem :(
  5. I cannot believe that nobody replied to this. I am having the exact same problem as the original poster. Can someone please respond to this? TOM maybe?

    If you've already installed WINDOWS 7 on your SATA drives, but it's showing up as an IDE device, how do you switch it to run as a SATA drive?

    I thought it was automatically detected by the bios that you've plugged in a SATA driver to a SATA port. Why would it show up as an IDE?

    Please, if anyone could help, this would be great. This is an old thread, but it still hasn't been answered, and we're all still having issues!
  6. I made the same stupid mistake myself once. I have a good excuse, but you don't really want to hear it, I'm sure. What I did was bite the bullet I keep in my pocket for just such occasions and do a clean install of Windows 7 after setting the BIOS to AHCI. That is the obvious straightforward fix, it's just a pain in the neck.

    There is supposedly a workaround where you leave the BIOS set to non-AHCI, change the Windows registry, reboot and set the BIOS to AHCI, but I've never done it. Google is often your friend, but I was afraid of my friend this time.
Ask a new question

Read More

Homebuilt Hard Drives Gigabyte Systems