Sign in with
Sign up | Sign in
Your question

Slow 6gbs on MSI P55a G55

Last response: in Motherboards
Share
May 9, 2011 9:16:03 AM

Hi guys,
I just bought a crucial M4 SSD (64gb) thinking it would blow my old Kingston SSD drive out of the water. After re-installing everything and getting it all up and running, I now find my benchmarks being half of what I would expect from the drive. I think this is because of the Marvell 9128 controller on the motherboard (MSI P55a G55)and it's firmware. It looks like there is an update for gigabyte boards that improves it's speed but I can't find a way of updating it on the MSI boards.

I do know that the speeds are slightly better using the intel ports but these are only 3gbs compared to 6gbs so still wont touch the drives tops speeds. So in short my ideal solution is to get the Marvell 6gbs ports working correctly.

Does anyone have any ideas how I can improve the speed of this drive, or update the firmware of the Marvell controller?... Also please tell me I wont have to re-install everything again ( I think my wife may leave me if I do :-) )

One other thing to note is I have two Samsung F3 1TB's in Raid 0 on some of the Intel ports and they are running about the same speed as the Crucial M4 at the moment.

Thanks guys.



More about : slow 6gbs msi p55a g55

May 9, 2011 10:38:59 AM

If it has ahci support in bios, and it's not turned on, that's your problem.

My setup:
Intel i7 2600k sandy bridge @ 5ghz
Water-cooled
Corsair 2133mhz ddr3 8Gb
Msi p67
2 Asus gtx570 directcuII in sli
1000 watt 80 plus bronze psu
120gb ocz ssd vertex 2
1tb hd 7200rpm 64mb cache sataIII dual processor
Wind tunnel case

-sent from my ipad 2!
May 9, 2011 10:56:19 AM

ACHI is already enabled. But I still get faster speeds if I plug into the Intel controllers at 3gb/s. Thing is these are limitied to 3gb/s so although it's faster, it still doesn't get close to the 450mbs of the drive.

Using AS SSD and the drive hooked up to the Marvell 6gbs port I'm getting around 220mbs read speed but the drive is meant to be around twice this. Very disappointed so far as it's pretty much the same speeds as the RAID 0 speed of my two Samsung F3's. The whole point of the small SSD was to have faster boot times but it's not reaching it's potential.

I'm guessing that the 6gb/s ports are limited by there current firmware but there isn't an update that I can find right now. The only one I found so far is for a gigabyte boards only. I dont know if I can install a generic firmware (seeing as this controller is onboard not stand alone) or even know where to find one that would work.
Related resources
Can't find your answer ? Ask !
a b V Motherboard
May 9, 2011 11:59:45 AM

lol typical msi for you
May 9, 2011 12:05:17 PM

The board had great reviews from several sites before I bought it. I'm just shocked they can release product saying it's faster 6gb/s when actually it's slower.

Fingers crossed someone can help on here.
!