Sign in with
Sign up | Sign in
Your question

No sound in UT with ALSA (Linux)

Last response: in Video Games
Share
Anonymous
July 2, 2004 11:13:40 AM

Archived from groups: alt.games.unreal.tournament (More info?)

So, with OSS everything was more or less ok, but something itched and I
switched to kernel 2.6.7 and ALSA. Now I don't get any sound in UT99. Is
there a solution to this?

ty

--

Bora Ugurlu
mailto:boraugurlu@yahoo.de

More about : sound alsa linux

July 2, 2004 1:37:49 PM

Archived from groups: alt.games.unreal.tournament (More info?)

Bora Ugurlu enlightened us with:
> So, with OSS everything was more or less ok, but something itched
> and I switched to kernel 2.6.7 and ALSA. Now I don't get any sound
> in UT99. Is there a solution to this?

Did you remember to load the OSS modules? Give us the output of
'lsmod'. What kind of card do you have?

MeltDown
--
!For all your UT99/2k3/2k4 questions visit UnrealTower's FAQ section:
! http://www.unrealtower.org/faq
!Home of the FAQs for agut and agut2003.
Anonymous
July 3, 2004 2:07:33 AM

Archived from groups: alt.games.unreal.tournament (More info?)

MeltDown schrieb:

> Did you remember to load the OSS modules? Give us the output of
> 'lsmod'. What kind of card do you have?

Hmm, I think I unchecked the oss-emulation during kernel compilation. I'll
have to look into that..

It's a good ol' Soundblaster Live.

output of lsmod:


Module Size Used by
snd_emu10k1 97960 -
snd_rawmidi 22112 -
snd_pcm 96100 -
snd_timer 24904 -
snd_ac97_codec 69352 -
snd_page_alloc 11468 -
snd_util_mem 4420 -
snd_hwdep 8320 -
snd 48152 -
ppp_deflate 6148 -
zlib_deflate 22040 -
zlib_inflate 22180 -
bsd_comp 5924 -
ppp_async 12068 -
ppp_generic 29080 -
slhc 7748 -
nvidia 2075432 -
ntfs 92172 -
af_packet 21900 -
vfat 14468 -
fat 45728 -
soundcore 9728 -
usblp 12772 -
joydev 9632 -
via_rhine 21292 -
emu10k1_gp 3460 -
gameport 4516 -
via_agp 8580 -
agpgart 33320 -
ohci1394 35400 -
ieee1394 110904 -
uhci_hcd 32244 -
thermal 12564 -
processor 12776 -
fan 3856 -
button 6172 -
battery 9264 -
ac 4688 -
rtc 12316 -



>
> MeltDown

--

Bora Ugurlu
mailto:boraugurlu@yahoo.de
Related resources
July 3, 2004 2:13:09 AM

Archived from groups: alt.games.unreal.tournament (More info?)

Bora Ugurlu enlightened us with:
> Hmm, I think I unchecked the oss-emulation during kernel
> compilation. I'll have to look into that..

Yep, that might be it.

> It's a good ol' Soundblaster Live.

Should work, I've got a SB Audigy, which has the same chip. You could
also try putting the following in your ~/.openalrc

-------------------8<-----------------------
(define speaker-num 4)
(define devices '(alsa))
(define alsa-out-device "surround40:0,0")
------------------->8-----------------------

MeltDown
--
!For all your UT99/2k3/2k4 questions visit UnrealTower's FAQ section:
! http://www.unrealtower.org/faq
!Home of the FAQs for agut and agut2003.
Anonymous
July 3, 2004 5:32:10 PM

Archived from groups: alt.games.unreal.tournament (More info?)

MeltDown schrieb:

>
> Did you remember to load the OSS modules? Give us the output of

update: that was it, after compiling oss compatibility module I have now
sound everywhere.

Cheers,

--

Bora Ugurlu
mailto:boraugurlu@yahoo.de
July 4, 2004 7:21:57 AM

Archived from groups: alt.games.unreal.tournament (More info?)

Bora Ugurlu enlightened us with:
> update: that was it, after compiling oss compatibility module I have
> now sound everywhere.

Good :) 

MeltDown
--
!For all your UT99/2k3/2k4 questions visit UnrealTower's FAQ section:
! http://www.unrealtower.org/faq
!Home of the FAQs for agut and agut2003.
!