Sign in with
Sign up | Sign in
Your question

Buffalo HD-PCTU3 NEW NOT WORKING

Tags:
  • Buffalo
  • HD
  • Storage
Last response: in Storage
Share
October 5, 2012 6:03:12 AM

hi ,

i purchased buffalo HD-PCTU3 two month back and now it is not detected by my laptop following are the symptoms

1. blue light glows and drive spins when i connect to USB but computer doesnt show anything
2. sometimes onli drive spins and no light and computer doesnt show any drive
3. i tried in other computers as well , same thing happened.
4. i had installed the driver in the drive before already

thanks!

More about : buffalo pctu3 working

a c 102 G Storage
October 5, 2012 6:58:03 PM

Please don't post the same question multiple times.

Have you tried another USB cable?
m
0
l
October 13, 2012 10:04:10 AM

parbat said:
hi ,

i purchased buffalo HD-PCTU3 two month back and now it is not detected by my laptop following are the symptoms

1. blue light glows and drive spins when i connect to USB but computer doesnt show anything
2. sometimes onli drive spins and no light and computer doesnt show any drive
3. i tried in other computers as well , same thing happened.
4. i had installed the driver in the drive before already

thanks!


Did you have any luck? Mine just started doing the same thing.
m
0
l
October 15, 2012 3:34:38 AM

guys i tried changing the cable as well didnt work , same issue.. and my cable just runs fine with another buffalo HD... i think im pretty sure its not the cable issue now!! the harddrive has some problem....and *** i got it from china...and i dont have any buffalo support in Nepal...my money is long gonee now!!FUCKKK!
m
0
l
a c 102 G Storage
October 15, 2012 2:04:18 PM

The problem may be the enclosure and not the drive itself.

You could disassemble the drive and remove the actual HDD. Then you could re-install the HDD into a cheap external enclosure to see if you can access the drive. You should be able to find something suitable in Nepal.

When you remove the drive, determine if it is a 2.5in or 3.5in drive. Also, verify whether it is SATA or IDE. Then get an enclosure to match.
m
0
l
!