Sign in with
Sign up | Sign in
Your question

CPU instal, what am I doing wrong?

Tags:
  • CPUs
Last response: in CPUs
Share
September 25, 2010 8:49:44 PM

I am attempting to install an AMD Athlon II X4 645 into a Dell Inspiron 518 Desktop and am having some trouble, I'm afraid I might have killed my PC but I'm hoping I'm just missing something obvious.

I opened up the cse and pulld out the old heat sink and processor, set the new one in the socket, locked it in, set the new heat sink in (it came pre-greased) locked it down and plugged it in. I also hooked up a new hard drive while I was in the but, I think, that's ancillary. Onc everything was put back together I plugged everything back in and fired it up. Nothing came on screen. I could see that the fans was running but nothing else was happening, no beebs, nothing.

Frustrated I tried undoing what I had done, pulled out the new chip, carefully cleaned the thermal grease off the old one, put on a fresh layer and reinstalled it and its heat sink. Same result.

What have I dne and how cn I fix it?

Link to Inspiron maual/specs: http://support.dell.com/support/edocs/systems/insp518/e...

More about : cpu instal wrong

a b à CPUs
September 25, 2010 9:18:27 PM

dued you do not support the athlon II line, u support up to phenom x4, and i would suggest you try to keep the tdp at 95 watts so he most powefull cpu you will suport is the phenom x4 9650
m
0
l
!