Sign in with
Sign up | Sign in
Your question

HD 4870 Problem

Last response: in Graphics & Displays
Share
June 17, 2010 2:30:36 AM

Hey,
I just downloaded the driver version 10.6 from the AMD site (selecting the applicable card and OS, obviously) and after doing a custom install, instead of a message of completion with a green check mark, there's a message saying warnings have occurred with a yellow question mark. When I open the log, no warnings or errors are listed. Also, what I noticed is that there is no more Catalyst Control Centre on my PC, but there is a Catalyst Install Manager. I tried uninstalling the card using both the AMD uninstaller and the device manager and then reinstalling. Nothing seems to be working.
How do I get CCC to work and can someone tell me what the Install Manager is for?
Thanks for your time,
Spike
P.S. I have Windows 7 HP 64-bit if it means anything.

More about : 4870 problem

a c 189 U Graphics card
June 17, 2010 3:23:14 PM

What card?
What motherboard?
PSU?

Try install the driver which came with the card in CD...
June 17, 2010 6:22:03 PM

I have a HD 4870 and a Gigabyte EX58-UD5 mobo. I don't see the relevancy but the PSU is rated at 750W.
I tried installing the drivers from the CD and the same message came up. When doing the custom install, There is no Catalyst Control Centre or Drivers options for the install. It's only Catalyst Install Manager. To add to that, upon rebooting, I get a message saying "Could not load file or assembly 'MOM.Implementation' or one of its dependencies. The system cannot find the file specified." These are all new things which seems puzzling. The only way I can update my drivers is through device manager and direct it to the unzipped driver file.
Does anyone have some info on what I can do?
I don't want to go to a fresh install of Windows but I'm considering it near the end of the month since it will also clean up my machine and speed it up a little.
!