Sign in with
Sign up | Sign in
Your question

Slow Read Speeds from RAID Across Network

Last response: in Storage
Share
October 6, 2012 9:23:01 PM

I have spent many hours trying to solve this. I have done pretty much every update, TCP Optimizer, etc. with not much difference in speed from the raid.

I have an AMD based system with Windows 7 Pro 64 acting as a file server. For the operating system and local storage it has a Western Digital 320 Green drive. It performs pretty much as expected and its read/write speeds are pretty close local or across the network.

I also have (2) 2TB Western Digital RE4 enterprise class drives on an Adaptec 6405E controller running RAID 1. These were to be used as the file server for our small office.

Here is where things went a little weird. After a few weeks, the speed of the RAID got unusable from the workstations. Using Parkdale, I timed as slow ad 16 KB/sec!

I went through everything and then tried partitioning the systems main drive to see what would happen. It worked better than the RAID! So, after hours on the phone with Adaptec, they sent me a new 6405E, which I didn't think was bad.

The new card is working well. I transferred all files and reformatted both drives in the RAID. After the RAID was rebuilt, the local speeds are great, but the remote speeds are weird. Here are the times I am getting, local (testing from the file server) and remote on both the RAID and the local 320 GB drive.

RAID Local - Read 234.8 MByte/sec - Write - 133.8 MByte/sec
RAID Remote- Read 43.0 MByte/sec - Write - 88.7 MByte/sec

320 Local - Read 80.9 MByte/sec - Write - 75.9 MByte/sec
320 Remote- Read 76.2 MByte/sec - Write - 78.5 MByte/sec

There seems to be some issue between the PCIe slot the RAID card is in and the network.

By the way, just to be safe, I also bypassed the on-board LAN with an Intel and it made NO difference.

Ideas? Suggestions?

Thanks in advance...

a c 86 G Storage
October 6, 2012 10:05:08 PM

A bit more info about the system, like mobo, ram, CPU and so on would be helpful. Anti virus running on the "server"? What about CPU load? Any hints in event viewer, especially timeouts? And how many SMB connections do you have open, when doing the tests?
m
0
l
October 6, 2012 11:51:07 PM

ASRock 970 Extreme 3 Motherboard
AMD Athlon II x2 3000MHz
G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900)
Microsoft Security Essentials is the only Anti-Virus

When it completely crapped out, there was a weird load on the CPU. It was one of the "system" generic things. One of the "visual" symptoms was that the drives would show almost full (red graph under them) even if it was really 99% free.

I was concerned about a virus, so I completely erased the OS partition and reloaded W7P. The issue remained. In fact, the other (320) drive started to be affected. When I pulled the Adaptec card, the 320 drive responded "normally" again.

When Adaptec had me send them a "report" log from the old controller, they said there was nothing in it. Not one error.

We have a total of 4 systems in the network, the "server" and 3 workstations. When these tests were done. it was just 2 systems and nothing else was happening on the network.

m
0
l
a c 86 G Storage
October 7, 2012 11:19:10 AM

Well, getting really difficult here. Only things i can suggest:
- try the Adaptec in a different slot, also in on of the 16x
- try disabling Security Essentials for a test
- i guess you updated the AMD chip set drivers already
- a checkdisk on the raid drives, because the Adaptec logs bad blocks, but not NTFS errors
- find out, what the CPU load causes. C:\Windows\System32\resmon.exe may be of help
m
0
l
!