Sign in with
Sign up | Sign in
Your question

SSD Problem: IDE Much faster than ACHI

Last response: in Storage
Share
October 7, 2012 8:52:54 AM

Hi Guys,

I have a strange problem and was hoping someone could give me some help.

I bought an OCZ Agility 3 240gb SSD and installed Win 7 Pro 64 bit. The problem is that when I set my BIOS to IDE mode, it for some reason is much faster than when I set it to ACHI mode:

ACHI:
http://i.imgur.com/RZewK.jpg

IDE:
http://i.imgur.com/yTdOZ.jpg

In ACHI mode my WEI for hard drive is between 5.5 - 5.7. In IDE mode I get 7.1.

I installed win 7 when in ACHI mode. I then installed my chipset driver from http://uk.asus.com/Motherboards/Intel_Socket_775/P5Q_Turbo/#download.

I have tried many different RAID drivers to try and fix this problem including the one that comes over windows update, and 3 different versions of the IntelĀ® Rapid Storage Technology driver (interestingly version 8.9.0.1023, which is on my mobo's website, causes my computer to crash on the windows loading screen).

I have also tried flashing my BIOS to the latest version but still with no luck. My SSD's Firmware came with version 2.22 which is the latest version.

Specs:
Asus P5Q Turbo
OCZ Agility 3 240gb
Intel Core 2 Duo E8400 3GHz
4gb RAM (2 sticks, OCZ DDR2 PC2-8500)
Gainward GTX 260

Any help much appreciated!
a c 353 G Storage
October 7, 2012 2:17:44 PM

Both scores are very load. The agility III should have an overall AS SSD score in around the Mid 400's. And just as a side comment, they DO NOT score any better when on SATA III port, so they are a good choice for a SATA II port UNLESS planning on Upgrqading the MB.

One - do not need "raid" drivers. Unless you have a pair of HDDs setup in raild 0 or 1. Intel driver prior to ver 9.5 is a rather poor SSD driver.

Two The drivers you pointed to (for intel chipset) is way out of date. For Intel RST drivers, the Oldest you want to use is version 9.5, they are currently up to 11.6.
Do Not think any diff between english and UK, so
http://www.intel.com/p/en_US/support/highlights/chpsts/...
October 7, 2012 2:52:22 PM

Thanks for your response RetiredChief,

I realize both scores are very low, I'm thinking there must be a problem with how ACHI is operating on my system to cause such a low score.

I've just tried the latest RST drivers but still no difference in speed :( .
a c 144 G Storage
October 7, 2012 11:46:55 PM

After I read the manual, I think maybe you connect the SSD to the SATAII 0 port (orange) or SATAII 1 port (white), which is from silicom image. If yes, you need to connect to the intel SATA 1-5 ports (red).

Yes your both scores are very low, and the RST driver will not help either. Most time like the intel and msft AHCI driver can do the good job, and 3rd party drivers don't.

By the way if you want to use the toolbox from OCZ, you can't install the intel RST because it isn't compatiable with intel RST, it only works under msahci driver.
!