Sign-in / Sign-up
Your question
Solved

External HDD showing in hardware devices but not in "my computer"

Tags:
  • Hard Drives
  • Computer
  • External Hard Drive
  • Storage
Last response: in Storage
October 7, 2012 11:15:46 PM

I hope this is the right place to post. So I gave my friend my seagate external. I plug it in and open my computer and the icon is not there. I go to control panel, hardware devices and it shows it. So I guess it is recognizing it. The laptop is a Dell Inspiron model p07e. When he plugs his ipod in Itunes recognizes it. It is windows 7 64 bit. Any help please

More about : external hdd showing hardware devices computer

Best solution

a c 82 G Storage
October 7, 2012 11:31:58 PM

Windows often fails to auto-assign adrive letter to external drives, but you can do it manually:

Control Panel > Admin Tools > Computer Management > Disk Management
Find the ribbon in the bottom-right pane which represents that ext drive.
Right-click it and choose "Change Drive Letter & Paths.
Click "New" then choose a drive-letter from the drop-down box.
Share
October 7, 2012 11:54:56 PM

Alright I did all that and this is what happened when I went to change drive letter:

"The operation failed to complete because the disk management console view is not up to date. Refresh by using the task. If problem persists close disk management console, then restart management or restart computer". I did all that and I still get the same error.

m
0
l
Related resources
October 8, 2012 3:38:24 PM

Just a regular windows update? Because that was done already
m
0
l
October 15, 2012 12:25:33 AM

Best answer selected by ghost261.
m
0
l
August 6, 2015 5:11:27 AM

Thank you so much phil22 and ghost261 . I had the same problem and its now solved..
m
0
l
August 23, 2015 11:53:26 AM

phil22 said:
Windows often fails to auto-assign adrive letter to external drives, but you can do it manually:

Control Panel > Admin Tools > Computer Management > Disk Management
Find the ribbon in the bottom-right pane which represents that ext drive.
Right-click it and choose "Change Drive Letter & Paths.
Click "New" then choose a drive-letter from the drop-down box.


I have tried this phil, But when i right click on the ribbon the option of Change Drive Letter&Paths does not appear
Need some help
I have an Old WD My Passport which detects perfectly... Just got a new WD Elements, But it doesnt show in My computer, just shows in the hardware
I've got Windows 8.1
Please revert back Asap

Thanks
m
0
l