Sign in with
Sign up | Sign in
Your question

Nvidia Drivers 257.21 SLI Corruption

Last response: in Graphics & Displays
Share
June 18, 2010 12:35:52 AM

I downloaded the latest released Nvidia drivers vs 257.21, and experienced severe graphic jumping while running 3DM06 in SLI, I'm running 2 260GTX in SLI, and as a single card run there was no problem, so I uninstalled the driver and went back to the previous release.

Has anyone else experienced this?
June 18, 2010 1:06:05 AM

Updating my Drivers right now for my GTX 260's, will give you update on this soon.
m
0
l
a c 172 Î Nvidia
a b \ Driver
June 18, 2010 1:19:12 AM

I haven't tried any SLi runs yet, too busy running around blowing stuff up in Just Cause 2. I'll try and give something a run tomorrow, as it's 2:15 am here and I'm going to hit the sack mate.
m
0
l
Related resources
June 18, 2010 4:21:07 AM

No problems here, but on another note did lose performance in BattleField BC 2?

Performance gain in 3dMark06 and Crysis.

Might want to try a re-install of updated drivers.
m
0
l
June 18, 2010 9:19:12 AM

^Good point, what hardware specs are you running?

AMD 965
MSI NF980-G65
4 G Kingston Hyper X 1600mhz
MSI 260GTX x 2
m
0
l
June 18, 2010 9:32:58 AM

AMD II x 2 @ 3.0Ghz
Gigabyte MA770-UD3
4GB's of Patriot Gaming in Dual Ch.1600Mhz
PNY OC Edition GTX260's SLi
7200RPM 1TB
m
0
l
a b Î Nvidia
a b \ Driver
June 18, 2010 9:34:50 AM

It would be better to test some games before rolling back to the older drivers Ryan.Install the 257.21 drivers again but this time do a clean install(uninstall the older drivers from the control panel,then download and install driver sweeper from guru3d.com and boot to safe mode,open driver sweeper and click on Nvidia and choose Clean,then boot normally to windows and install the new drivers)
m
0
l
June 18, 2010 9:42:57 AM

New Nvidia driver issues with game rendering!

OMG Crysis editor crashing on me now, well time to convert back to my GTX 260 driver disc lol.

Keep you all up-dated.
m
0
l
June 18, 2010 9:43:19 AM

I'd already rolled back to the older drivers and there was no problems at all with SLI, maybe there was some corruption in the download I'll probably re-download the driver and give it another try, I did like the improved SLI panel in the Nvidia control panel.
m
0
l
June 18, 2010 9:51:33 AM

Maziar said:
It would be better to test some games before rolling back to the older drivers Ryan.Install the 257.21 drivers again but this time do a clean install(uninstall the older drivers from the control panel,then download and install driver sweeper from guru3d.com and boot to safe mode,open driver sweeper and click on Nvidia and choose Clean,then boot normally to windows and install the new drivers)


Even with Nvidia's Unified driver architecture, some releases work great for some graphics cards and not so great for others, even though Nvidia claims different usually the next release includes a fix for the past problem, this is a big jump from the 197 series to the 257, so I'm quite sure they'll get the bugs out eventually, the 197 drivers work great for my setup anyway.

I was just curious if anyone else had the same SLI problems, and if various hardware combination's had something to do with it.
m
0
l
June 18, 2010 4:28:09 PM

Well, sometimes my driver won't boot, like it was uninstalled, so I have to install it again. Sometimes it also blocks SLI in my PC, but still recognizes both cards.

My system is:
i7 920 @ 3.2GHz;
6GB RAM;
2 gtx275 SLI;
Windows 7 64x Ultimate.
m
0
l
a c 172 Î Nvidia
a b \ Driver
June 18, 2010 4:49:14 PM

I just did a 3D '06 run with SLi enabled and didn't see any graphical corruption at all from the old GT's.
m
0
l
a b Î Nvidia
June 18, 2010 5:02:19 PM

i think this has to do with how this new driver handling SLi profile. if you're using 197 driver previously this new driver might screw up your sli profile. this problem also happen to people that using the beta driver before
m
0
l
a c 172 Î Nvidia
a b \ Driver
June 18, 2010 5:17:14 PM

renz496 said:
i think this has to do with how this new driver handling SLi profile. if you're using 197 driver previously this new driver might screw up your sli profile. this problem also happen to people that using the beta driver before

I just installed the 257.21 without uninstalling the beta 257.15 and that was installed over the top of the 197.57 beta and like I stated earlier, no corruption has been seen.
m
0
l
June 21, 2010 2:35:54 AM

Also want add one to the "these drivers are giving me problems" group. Significant performance hit in 3Dmark, any games containing 3D video suffering massive slow-downs. Running GTX 285 in SLI.
m
0
l
!