Sign in with
Sign up | Sign in
Your question

Retrieve data from Marvel RAID after migrating to SSD

Last response: in Storage
Share
October 8, 2012 5:41:14 AM




This is my experience going from a Marvel RAID C Drive configuration to an SSD one. Hopefully, I will be able to get some of my data back and at the same time give anyone else with similar configuration something to think about and some ideas.

1) I started out with a Asus P6X58D-E MoBo with a Marvel RAID 0 for my C drive and a 2TB Seagate HD for my documents. As a matter of course I never keep my OS and my documents on the same Physical drive and I usually tend to backup my data more than I do my programs.

2) This configuration has been working OK for me and I was deluded into thinking that my RAID 0 was keeping my OS saf"ER" than on a regular configuration and that the occasional quirks and weird BIOS issues was a small price to pay not to wake up on a bricked computer.
My problems with the Marvel RAID are not germane to this issue, ut they were annoying and one of the reasons I decided to change my computer configuration

3) Since SSD prices have dropped dramatically and since I bought my computer I got pretty seriously into online Simulation car racing, I decided I wanted more speed out of my machine. plus it took forever to boot up each time. So I purchased a Samsung 250GB SSD and a Seagate Barracuda 2TB.
The idea was to:
a) Install the SSD as C drive
b) Install the Seagate 2TB as my document folder.

My plan for the existing drives was as such:
a) Keep the MArvel RAID as a dual Boot until I completely migrated and installed all my application on the new SSD.
b) Use the old "Document" hard drive as a local backup and move only the most important documents to the new shiny one.

The main reason I wanted the dual boot between the SSD and the marvel was so I wouldn't have to waste an entire weekend installing stuff.

4) I researched as much as I could but eventually last Friday I decided to at least mount the SSD and the 2TB HD to see if they worked OK and generally see if my board was going to be OK with them. If it was, then my next step would have been to install Win 7 into the SSD and start my adventure.

Turns out that my Asus MoBo has a total of 8 SATA III ports.
There is a set of 6 ports side by side but the top 2 ports are not SATA 1 and SATA 2, but they are the two Marvell SATA ports. and the are 6GB ports.

Below them there are 2+2 SATA III ports (6GB), again side by side, then, past the corner there are an additional 2 ports (the manual calls them "blue") they are still SATA III ports but with half the throughput at 3GB.

I left the Marvel RAID drives alone and I installed the SSD into one of the 6GB SATA III ports that was empty ans the 2TB HD into one of the Blue ports.

I went to start the computer again expecting to have to format the droves and such and....

NOTHING. No BIOS, Nothing at all. My computer bricked.

No problem, I thought. That pesky SSD is messing up my board. maybe I missed a warning. So I immediately decided to unplug the SSD and restart.

Same thing. Computer starts, but it never even gets to the BIOS.

I am starting to panic. I disengage the 2TB HD as well just in case. Nothing. I am contemplating a very expensive brick. No matter what I do, I cannot restart my computer.

At this point, I decided to go for broke. I have an SSD, I have an additional HD and I know my data is pretty much safe (Or so I thought).

5) I grab my Win 7 disk, I get into the cas and I unplug the SATA II of the RAID and plug back in the SSD and the 2TB HD. I hit restart and the BIOS pops up.
I set the CD ROM as the first device to lad from and sure enough I am able to install Windows 7 on the SSD. VICTORY!

I spend a few hours installing MS Office, my Adobe Suite, and a myriad of programs, plus my beloved Driving Simulation games.
That's when I first realized I had to have access to my old C drive because a lot of very time consuming customization is saved on that RAID drive. Not only the games and the mods are saved there but my very "Racing identity" is saved there. Hours worth of driving around virtual tracks to gsain that elusive 1/10 of a second.Had I known that I was going to brick my computer I would have certainly backed those up.

But for the moment, I am not too worried: my computer is a beast. I had installed an extra 6GB of RAM for a total of 12. With the SSD and a fresh copy of Windows, this computer actually does things before I can even think about them.

Restarts are so fast that I could not believe it was possible. It's almost as fast as my iPad to boot up. I was in heaven!

6) I checked my "Carbonite" files and to my relief I see that the "Games" folder, where all my precious files are was backed up. I don't need the Marvel Drives after all.
But as I go and check the integrity of the data, I realized that even though the data has been there for months, it was "waiting to backup". I think Carbonite doesn't like how much data I am backing up and it lets me know that way. Not happy.
But no closer to my data either. I have it right here in these Hard drives.

7) I make the decision to try to hook up the Marvel drives again, hoping that now with a brand new version of Win 7 on a superfast SSD they would load as just another hard Drive or at least give me the choice to boot up from the SSD or from the Marvel RAID.

I trepidantly turn off my computer. Get back into the case and hook the RAID back up (I always make diagrams and take pictures of everything I do). I plug back the power and hit "Restart". The computer starts but I can tell it sounds anemic. The cooling fans don't have that steady humming sound but rather they sound like an old car trying to negotiate a steep hill. WooOOooo, WooOOooo, and so on. The power light is not Blue as usual, but an Anemic Yellow.
Most importantly, the BIOS doesn't load!!!

8) I try restarting over and over with different configurations. No RAID. OF course it is the first thing I revert. I immediately revert the configuration to what last worked. but it doesn't help. I then take out all the USB peripherals, then I take out all the drives drive (just the SSD). Eventually, 3 hours later I am despondent and contemplating ruin when I hit the power and magically it starts. I am in the BIOS again.

Honestly, I have no idea what I did, aside from waiting a very long time with the power cable off.

The reality here is that all I am trying to do is to mount hard drives onto a MoBo. Something I have been doing more or less on autopilot for 20 odd years. Why am I having such hard time?


Evidently my MoBo really doesn't like change. Adding an SSD almost bricked (or actually did) my whole computer. Just to be sure, I am looking to replace the power supply. Maybe I'll buy a better brand, but I doubt that's the culprit.

my biggest problem is this: I need to get into my Marvell Raid before I turn those two drives into storage.
I tried mounting one into a external case and hook it via USB, but it's not recognized as a drive. I need to have it run off my MoBo, but I am very worried that it's going to brick my computer again, this time for good.

Does anyone have any ideas?

And here is the moral of this story: Even though you think you have thought of everything, even something as innocent as installing an extra Hard Drive can foil your plans. I never imagines, when I installed the SSD that it was going to be the last time I would see my own computer.

Also, do not trust Carbonite. Go deep into those folders and make sure that those you are looking at are really files. In my case it turned out they were placeholders for files eventually Carbonite was going to get around to backup.

Anyway, I know it's a long story, well, it was a long weekend and it ain't over. I could really use some help with my Marvel Raid. I need to get in, get my files and get out, then I'll burn them if I have to.

Thank you for reading so far. Any help will be greatly appreciated.


Here are my specs before the new drives, RAM, etc.

OS: Windows 7 Professional Professional Media Center 6.01.7600 (64-bit)
Processor : Intel Core i7 970 3200MHz - (OC to: 3502.34MHz) - Number of Core : 6
Physical Memory : 6144MB [2 GB X3] DDR3-1600 - Corsair Dominator
Video Card : NVIDIA GeForce GTX 460
Hard Disk : Seagate ST32000542AS ATA Device (2000GB)
Hard Disk : MARVELL Raid VD 0 SCSI Disk Device (1000GB)
DVD-Rom Drive : Optiarc DVD RW AD-7260S
Monitor Type : ViewSonic VX2235wm - 22 inches
Mainboard : Asus P6X58D-E
Physical Memory : 6144MB DDR3-SDRAM
Network Card : Marvell Semiconductor (Was: Galileo Technology Yukon 88E8056 PCIe Gigabit Ethernet Controller
Bios : American Megatrends Inc.
Chipset : Intel X58 LPC bus : Yes | PCI Bus: Yes | Bus PCI-Express: Yes | USB Bus: Yes | SMBus/i2c Bus: Yes
Bus HyperTransport: No | Bus QPI:Yes | Bus CardBus :No | Bus FireWire:Yes
October 8, 2012 6:26:33 AM

I wanted to quickly ad that I found this software while researching the issue of retrieving data from a RAID 0 set of Hard drives:

http://www.***/

This program is pretty amazing. I placed both disks into enclosures and connected them via USB. Immediately the software recognized them and now it's working on them. Looks like it will go overnight, but this is far better than anything else I have read so far.
My situation is a bit different than the horror stories I have been reading about, I could reconnect the drives and see how they go, but I am just not about to spend another 5 hours reviving a computer. I'd rather invest time trying to retrieve the data than bricking my computer again.
a b G Storage
October 8, 2012 8:31:45 AM

Samsung 830/840 are my recommend for SSD's.

Do you have any more questions?
October 8, 2012 5:48:28 PM

That's a good recommendation. I am currently using a Samsung 830. My computer has never been as fast as in this incarnation.
!