Sign in with
Sign up | Sign in
Your question

Reinstalled Windows, now ethernet cables don't work.

Last response: in Networking
Share
March 24, 2010 5:41:40 PM

Hi, I reinstalled windows today because my computer had a virus, and the anti virus software deleted it, but it turned out run.dll was deleted, so I had to reinstall.

Now, when I plug any ethernet cable into the back of my PC, nothing happens. I seem to remember that before when I plugged it in there was a light that came on in the socket, but now that doesn't happen.

The basic setup I use is an ntl cable modem, which is connected to a Belkin N F5D8236-4 v3 router, which in turn has several ethernet cables plugged into it, one going to my dad's computer and one going to mine. They are both right next to each other, and on my dad's PC the internet works perfectly.

I have tried connecting my PC to the router with severl ethernet cables, and also connecting the modem straight to my PC. Nothing works.

Thanks for reading, I appreciate it. This problem is incredibly frustrating, since reinstalling windows was an inconvenience enough without this.
March 24, 2010 6:15:08 PM

Have you reinstalled the drivers yet?
Check in device manager and look for any yellow question marks.
March 24, 2010 8:32:25 PM

sturm said:
Have you reinstalled the drivers yet?
Check in device manager and look for any yellow question marks.


I will do this tomorrow, thanks for the advice. Also, something I forgot to mention in the original post is that when I run the setup from the manufacturer's DVD it does not detect any device plugged into the PC and so cannot continue with the setup. I'm not sure if this setup would install the drivers.
Related resources
March 25, 2010 2:42:45 PM

sturm said:
Have you reinstalled the drivers yet?
Check in device manager and look for any yellow question marks.


In Device Manager, under "Other Devices", there three entries, "Ethernet Controller", "SM Bus Controller", and "Unknown Device". All of the have yellow exclamation marks next to them, not question marks.

When I try and update the drivers windows searches for updates on all three of them and can't find anything. Scan for hardware changes doesn't work. This is with the router setup disk in the drive by the way.
September 1, 2013 3:57:02 AM

I have the same problem i reinstall my cousin's laptop because when he enter his profile his laptop lags and can't continue. After reinstall i tried to enter the cable but there is no connection. I enter device manager how u said and when i click on other devices there eppeared 4 things. Ethernet Controller, Network Controller, PCI Simple Communications Controller and SM Bus Controller. They have "!" and when i click them and enter their properties i saw that all of them need to update. The problem is that i can't update them without internet. How can i update them? Please tell me i have to give him back the computer today.
September 1, 2013 4:25:14 AM

You have to go to manufacture site and download them to some media that you can read with a different computer. USB stick is easiest but sometime you need even those drives so you will have to use cd/dvd method.
!