Sign in with
Sign up | Sign in
Your question

ASRock 890GX Pro3 AM3+: Can't access the UEFI BIOS

Tags:
  • Chipsets
  • BIOS
  • Mice
  • Motherboards
Last response: in Motherboards
Share
May 17, 2011 3:43:17 PM

Have just received my new AM3+ 890GX board and it is an awesome setup, but: After installing everything and updating everything I try to go into the new "awesome GUI" UEFI BIOS and, NOTHING! All I get is a frozen black screen with a white mouse arrow cursor in the middle and the letters "AB" in the bottom right hand corner. I have to hard reset to get out of it.
I've updated the BIOS to their latest(v1.30) and updated all other drivers. Tried reverting back thru their BIOS releases down to the original. Tried a different mouse. Tried clearing CMOS over and over. I've searched the web with a hundred different "UEFI, BIOS, POST, access" etc word combinations and all I find is people saying they had to update their BIOS to access it. Didn't work for me.
Most of settings are stuck at stock and below now and it's really pissin me off. Anyone who has suffered this and fixed it or has any advice please give a reply. Of course I've gotten no response from ASRock so this may be going back to NewEgg in the next few days. I just purchased this one to replace another board that is in the middle of RMA that had burned out recently so I really don't wanna go thru that BS again.

More about : asrock 890gx pro3 am3 access uefi bios

May 17, 2011 8:11:29 PM

Okay, so it's just an issue with my display (Samsung 42" 1080p on HDMI). I just got an urge to try an old CRT monitor I got layin around and it loads into the UEFI with no problem. Kind of strange, guess the UEFI just doesn't support that type of output. Never had an issue with this as my monitor before with anything. So solved with no RMA, yah!
m
0
l
!