Powercolor HD 5750 choppy desktop graphics

I just built a new system with the Powercolor HD 5750 1gb on a Gigabyte GA-870a mobo and Phenom II x6 1055t cpu.

I am experiencing some choppy movement on the desktop. For example, when I click a window and drag it around, the window movement appears choppy at times. Also when you shut down windows, the ending gradient fade is not very smooth at all. However, it seems to have no problem playing video or games (batman arkham asylum).

I have the latest catalyst drivers. My mobo bios is the F1 bios. There is an F2 bios that came out around last week. It said it has an AGESA 3.7.0.1. My F1 bios seems to recognize everyone now, so I'd rather not take the risk of flashing the bios.

Any idea what's going on with choppy desktop graphics?
7 answers Last reply
More about powercolor 5750 choppy desktop graphics
  1. Try increasing the idle clocks
  2. Re-install the driver for your card?
    It seems like you have a problem with 2D...
    Also try as JRYAN388 said above..
  3. Don't go with flashing BIOS, it's little risky.

    This can be problem with drivers, try uninstal with driversweeper in safe mode and instal again.

    http://www.guru3d.com/category/driversweeper/

    Or in last case instal fresh copy of Windows...
  4. A better way to describe the problem is that when I drag around windows, I see a trailing border. I think this may be linked to my usb wireless mouse. When I plug in a wired mouse, this does not happen. However, the gradient when you log into windows is still not very smooth.
  5. robertdo said:
    A better way to describe the problem is that when I drag around windows, I see a trailing border. I think this may be linked to my usb wireless mouse. When I plug in a wired mouse, this does not happen. However, the gradient when you log into windows is still not very smooth.

    Have you driver with that mouse? If you have try uninstal and again install...

    And go in Control Panel/Mouse, try unchek some option
  6. Does this problem ONLY occur when you're in 2d mode?
  7. I used driver sweeper and reinstalled the drivers. Nothing seems to have changed. Yes, this only happens in 2d mode. 3d games like Modern Warfare 2 run very fine even at 1920 high settings.
Ask a new question

Read More

Radeon BIOS Desktops PowerColor Graphics