Nic problem

Built a new computer. Installed OS. Installed gigabyte mobo drivers. Everything worked fine. Installed a bunch of programs. And ran a bunch of windows updates. But after the 4th or 5th windows update the nic card suddenly wouldn't work. I ran thru the troubleshooter. Uninstalled it. And reinstalled it. Turned the computer off and on with the cable unplugged. Nothing.

There is a yellow exclamation point next to it in device manager.

Can anybody help me?

Patrick
9 answers Last reply
More about problem
  1. Hi there,

    Give the group more information about your new system, so we can hone in on the problem

    What make and model # MB are you using, OS, RAM, CPU, Video card, etc. If your MB does not have a NIC (or two) built in, what NIC adapter card are you using? Also, did you install the NIC driver with the MB drivers or separately?

    The yellow exclamation icon next to a hardware device in the device manager means there is a problem with either the driver, or the hardware.

    Double click on the hdw item to bring up the properties dialog box. Check the General Tab, and it will tell you if the component is working properly. If there is a problem with the hardware, it will give you a code "43" (as I recall) and say the hardware is not working properly and has been shut down.

    Also check the Driver tab and see if there is any helpful information.
    Next step depends on what you find.
  2. The warning is "this device cannot start (code 10). It's an onboard nic card. My system is thus:

    PROCESSOR AMD Phenom II X4 955 Black Edition $120 plus $10 gift card
    MOTHERBOARD GIGABYTE GA-870A-UD3 AM3 AMD 870 SATA 6Gb/s USB 3.0 ATX AMD $98 plus $10 rebate
    RAM G.SKILL Ripjaws Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) $40
    VIDEO CARDS SAPPHIRE 100293DP Radeon HD 5570 1GB 128-bit DDR3 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Low Profile Ready Video Card w/ Eyefinity $65 plus $10 rebate SYBA 6 ft. HDMI Male to DVI Male (24+1) Cable Model $7
    Hard Drive Seagate Barracuda ST3500413AS 500GB 7200 RPM 16MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive $40
    Case Antec Three Hundred Gaming Case External 3 X 5.25; Internal 6 X 3.5 2*Usb2.0 $60
    Power CORSAIR Builder Series CX500 V2 500W $55 plus $20 rebate
    Optical ASUS DRW-24B1ST/BLK/B/AS Black SATA 24X DVD Burner $22
    KINGWIN CF-012LB 120mm Case Fan $6 x3
    OS Microsoft Windows xp $0
  3. Hi again,

    That error code 10 means the device is either not present, not working properly, or does not have all the drivers installed. (Code 10)

    First thing I'd do is go to the BIOS, and disable the Realtek NIC, then boot up to the desktop. Then go back and reenable it so the BIOS and OS recognizes it and sets the IRQ properly. If that doesn't correct it, go to the Device manager, on the NIC properties dialog box, driver tab, and uninstall the driver. Then either from the GB web site or your MB CD, reinstall the driver.

    If that doesn't correct it, read this KB article 276602 from MS that talks about a known problem they are aware of regarding this error, and they have a fix, but only for this very specific problem.

    That's why you want to try steps 1 and 2 first.

    http://support.microsoft.com/kb/276602

    Should be able to get your NIC up and running.
  4. Thank you so much. The windows update version of the driver does not work. But the one on my disc does. Fixed the issue. Once I manually selected it off of the disc. And then rebooted. Weird deal.

    Thanks again.
  5. Hi there,

    Glad you got it functioning again. It may be that the "bad driver" causing it to not function was picked up on a Windows Update where it scanned and downloaded "updated drivers". That could explain why it worked fine for a while, then at one specific point in time quit.

    It only academic, but you could look in "windows Update history" and it will list if and when that driver was downloaded. Then think back if that was the time the NIC stopped functioning.

    The satisfying feeling is that with just a little nudge, you picked up the ball and fixed the "bad driver" yourself. Nice going!

    John
  6. I made that same mistake once. I allowed windows to update my LAN driver. Drove me up the wall for a while.
  7. Tried to get this answered elsewhere. But thought maybe you guys might know:

    It was late. I was tired. And an XP security update was taking FOREVER. I stupidly cancelled out of it. Assuming that windows update would pick up on which ones I had cancelled out of later. But after this Windows Update gave me no more security updates. Some other updates came up. But nothing related to security.

    Now I can't get Zonealarm to work. And it won't install or uninstall. I get an error saying vsutil.dll. I then tried using a couple different ZA removal tools to no avail.

    I think this was caused by my skipping the security update. But maybe they aren't related. AVG won't work either. But it says it's cause I don't have the proper license key loaded. Haven't tried fixing that issue yet.

    I feel like I am going to have to do a clean install of XP and start over. But man I don't want to. But I also don't want to rock it without a firewall either.
  8. I would go and undo all the updates for that day in windows update. Then see if you can properly update your comp.
  9. I just reformatted and started over from scratch. Up and running now. Just waiting on my adapter so I can run three monitors off the Radeon vid card.
Ask a new question

Read More

Gigabyte NIC Computer Motherboards