Sign in with
Sign up | Sign in
Your question

Radeon HD 5750 Problem

Last response: in Graphics & Displays
Share
June 21, 2010 3:50:20 PM

Hello,I Bought PowerColor Radeon HD 5750. I inI Bought PowerColor Radeon HD 5750. I installed it and then plug monitor to video card. When i boot my comp i get just black screen. whats Wrong?

More about : radeon 5750 problem

June 21, 2010 3:57:13 PM

Did you also plug in the power cord to the card?

What are your system specs including PSU rating? Even though the 5750 draws less power than some other video cards, if your PSU is severely underpowered, then you might not have enough power for the GPU.

That or you have a faulty GPU. Have you tried installing it into another computer to see if it works?
June 21, 2010 4:03:19 PM

System specs:

-m4a785-m pro motherboard
-AMD Phenom 4 core Processor
-modecom Premium 500w PSU

I just pluged card to pcie slot.
Related resources
June 21, 2010 4:38:25 PM

Mrdebitcard said:
System specs:

-m4a785-m pro motherboard
-AMD Phenom 4 core Processor
-modecom Premium 500w PSU

I just pluged card to pcie slot.


So, you didn't connect a chord to the 6-pin power connector on the card? If not, that's your problem.

You MUST hook that up as the card requires the extra power to operate.

This picture shows the connector in the lower right-hand corner:

June 21, 2010 5:04:33 PM

Chord was not connected but even when i connected it i still get same results...
June 21, 2010 5:56:04 PM

I'd RMA the card then. Sounds like you have a bad card.

That or your PSU isn't powerful enough for it. I've never heard of the manufacturer of your PSU, but even cheaply made PSUs that state they are rated at 500W perform a lot less adequately than they are reported to operate at. Even though it SAYS it's 500W doesn't mean it is.
!