Sign in with
Sign up | Sign in
Your question

ATI Catalyst 10.6 Breaks Older OpenGL Games

Last response: in Graphics & Displays
Share
June 21, 2010 5:12:45 PM

Installed the ATI Radeon Catalyst Driver Version 10.6 yesterday. Found that none of my older OpenGL games such as Quake, Quake 2, Hexen 2 work now. They crash to the desktop upon launch.

Anyone else experiencing the same issue?

System Specs:
Asus Radeon 5770 1GB Video Card
AMD Phenom II X4 965 Black Edition
Asus M4A77TD Motherboard
4GB Crucial DDR3-1333 Memory
June 21, 2010 7:33:06 PM

...why do I have the feeling Rage is going to horrendously break ATI cards?

Seriously, 10.4 broke enough OGL stuff...I'll test out later today and see if its the drivers.
m
0
l
June 22, 2010 2:08:32 AM

It did it to me too Anachronox won't work anymore ;.;

NOOOOOOOO!!!!!!

nhancer fixes this problem with nvidia cards via an extension limit, but with ATI we're out of luck...
m
0
l
Related resources
June 22, 2010 2:51:43 AM

If you don't want to mess around with the copy of atioglxx.dll in the System32 or SysWOW64 directory just paste the file into the folder your broken application is installed in. It fixed Anachronox for me :]
m
0
l
June 22, 2010 12:04:38 PM

Yeah, ATI messed up OGL support...again...
m
0
l
June 22, 2010 2:08:36 PM

I'll try the atioglxx.dll solution tonight... Hopefully ATI will fix their drivers soon.
m
0
l
June 22, 2010 4:21:19 PM

^^ We've been saying that in regards to OpenGL since Doom3 came out in 2002 (2003?)
m
0
l
June 25, 2010 12:48:34 PM

The atioglxx.dll solution did not work. I ended up uninstalling the 10.6 driver and reverting back to an older version.

Before I did this, I tested a few other games. Looks like Catalyst 10.6 breaks the following games: Return to Castle Wolfenstein, Jedi Knight Outcast, Quake 2, Quake 1, Hexen 2... Quake 3 actually worked which was kinda strange since RTCW and Jedi Knight Outcast are built using the Quake 3 engine.
m
0
l
July 4, 2010 6:06:39 PM

Yeah for me American Mcgee's Alice was still working and it uses the Quake 3 engine as well.
m
0
l
July 5, 2010 5:13:43 AM

I have been using 10.4 since it came out and I find it to be the most stable ATM. I have many old games like UT, SOF 1 and 2, whole quake series, RTCW series among many more and all of them work fine.
m
0
l
!