Sign in with
Sign up | Sign in
Your question

New Internal WD Hard drive not recognised

Tags:
  • Hard Drives
  • Western Digital
  • Storage
Last response: in Storage
Share
October 16, 2012 11:13:42 AM

I've just recently purchased a WD Caviar Blue SATA 3 internal hard drive for my PC (AMD athlon 64 X2 Dual Core Processor 3800+) as my old internal HD failed on me (had it for around 6 years). I plugged in the new WD HD but the Bios does not recognise it. I can hear it spinning up so the power cable works, I have tried two different sets of SATA cables on all 4 ports on the motherboard, tried to vary the odd jumper settings after having none for the first few trys but no luck. I don't have another PC using SATA to try it out on however I do have 2 old HD's which I have tried and they register as the Master and slave IDE. The slave wont load because its so old it has no memory (used Windows 95 on it) and my master IDE seems to get stuck on loading up Windows ME and I can only access it on safe mode so I can't look in the add hardware section of the control panel in safe mode.

I have thought about wiping my master IDE and putting Windows XP on it but I'd like to avoid that if possible as I don't wan to lose the files on it. Any suggestions on what else to test, jumper settings, cables etc would be appreciated? Thanks

More about : internal hard drive recognised

a c 138 G Storage
October 16, 2012 11:21:26 AM

check that the bios is set to achi mode for the sata. also check the drive to see if there a jumper to set it from sata 6.0 to sata 3.0 speed. the mb chipset may not be able to handle the drive on sata 6.0g speed. if the drive not found it could be a dead drive. one thing i would check is to see if wd has a firmware update for the drive if not. i try another sata drive.
October 17, 2012 10:36:33 AM

I changed the jumper setings on the Hard dve to make it Sata 3 which my motherboard can handle but it still didn't work. ithout sounding like a noob, but how can I check the Bios is in ACHI mode i.e. is there a likely section of the bios it should be under. I can't actually see any hard drive using SATA and my IDE hard drives can be seen but they wont load up due to one being old and the other one having what i'd imagine are boot driver issues so i'm stuck for downloading any firmware.

Slightly worried it could be the SATA ports on the motherboard but other than that i'm open to suggestions.
Related resources
a b G Storage
October 17, 2012 11:15:36 AM

btw how big is your new HDD?
some old mobo will had hard time recognize 3TB HDD...

Could u try different port ?

also try using other sata cables and power cables....
Also can u try changing the CMOS Battery (and meanwhile reset the CMOS)....

October 17, 2012 11:48:36 AM

Thanks for the reply.

It's a 500GB HDD, same as my last HDD. I've tried all four SATA connections, with two different SATA wires with and without certain jumper settings. I've only got the one power cable that works with a SATA drive but I can hear the HDD spinning up so i'd say the power cables working.

I'll have a go with the battery tonight and maybe check connections on the motherboard and hope I find something.
!