Sign in with
Sign up | Sign in
Your question

New SSD; now getting disk errors

Last response: in Storage
Share
October 17, 2012 5:40:24 PM

Hello all, new to the forum - so here's my issue. I recently upgraded from a 90gb OCZ Agility 3 to a 128gb OCZ vertex 4 for my boot drive. Windows installed with no problems. After updating windows several times and setting up all the programs I want etc., all of a sudden I'm getting random repeated errors "A disk read error has occured. Press ctrl+alt+del to reboot" when I start up. It seems to be solved by doing a hard reset and starting up again. I ran chkdsk on the drive and it came back good. When the machine starts up normally, it runs fine (no BSDs, slowness etc.) I have the new SSD on SATA 0 and the old SSD (formatted, not using dual boot) on SATA 1 on the motherboard, don't know if that would effect anything. I've checked the CPU, PSU, RAM and GPU on another MB so none of those are the issue. I've also swapped out the SATA cable with several known working ones with no change.
The one thing I have come across is in the BIOS, the size of the drive is shown but the drive has no display name, it just says 'None'. However, the drive name does show up in the boot menu. I am new to changing BIOS settings so bear with me on those issues.
Like I mentioned, the errors seem random and when the machine boots up normally, it's fine. Could it be a virus/malware creating this problem?

Specs below. Thanks!

GIGABYTE GA-970A-UD3 AM3+ AMD 970
AMD FX-4100 Zambezi 3.6GHz
CORSAIR Vengeance 16GB (4 x 4GB) 240-Pin DDR3
OCZ Vertex 4 VTX4-25SAT3-128G 2.5" 128GB SATA III SSD
SAPPHIRE Radeon HD 6850 1GB

More about : ssd disk errors

a c 353 G Storage
October 17, 2012 5:55:18 PM

Is he MB bios Up todate - Should use the latest Bios revision.
Check MB website for lates Bios.
If new the SSD should also have the latest Firmware Rev.
Check OCZ for latest firmware.
m
0
l
Anonymous
October 17, 2012 5:59:13 PM

Sounds like a mb issue, try getting latest bios. I also have the Vertex 4 256gb version. Make sure you installed it correctly according to numerous ssd install guides online. But it does sound like a mb issue. Possible bad ssd as well.

m
0
l
Related resources
October 17, 2012 6:08:40 PM

Thanks guys, quick question - will updating the MB BIOS or the SSD firmware require reinstalling windows?
m
0
l
a b G Storage
October 17, 2012 6:14:35 PM

no - but updating the FW on the SSD MIGHT clean the drive of its contents
m
0
l
October 17, 2012 6:48:35 PM

K, I'll try this and update later
m
0
l
November 9, 2012 6:54:05 PM

Well, after trying all of your solutions nothing worked, I RMA'd the drive and got a new one. Since then, no problems, turns out the drive was bad.
m
0
l
!