Sign in with
Sign up | Sign in
Your question
Solved

RAID 0 to single SSD

Last response: in Storage
Share
October 18, 2012 7:50:52 PM

I am exchanging my RAID 0 in my system for a single SSD (this is my system drive). Has anyone successfully cloned a RAID 0 to a single SSD and had it boot?
I've read on lots of forums and have got a wide range of responses. Some say it's just not possible, others say it's no problem, some say that it's possible if you do x y and z, etc. However I haven't seen any of the forums where the OP came back and said it x and it worked.
I have tried Apricorn EZ GigIII to clone the drives (I've used many times to go from single spinning disk to single ssd). and was unable to get the drive to boot. Kept getting Missing BootMGR. I tried all the solutions for that I could find with no success.
I also have Acronis True Image 2012 with the Plus Pack. I have tried cloning, as well as booting to the bootable media and recovering the back up of my RAID 0, this again gives me boot errors that I find solutions for and still won't boot. Also tried putting a fresh install of windows on the new drive, then recovering the back up again with no luck.
I was also online with acronis support last night and they said it should work but never got it to.

Has any one successfully done this and if so what steps did you use? I know the best solution is a fresh install, however this is my production machine and it would be last resort for me to have to have my machine down for a day installing programs and getting all the preferences set back up.

Windows 7 x64. MoBo - Asus M5a97evo

thanks for any help

More about : raid single ssd

a c 324 G Storage
October 18, 2012 9:58:34 PM

Yes. Although I usually recommend a clean install, I cloned my first SSD from a pair of RAID 0 raptors. I used Ghost 15, but EaseUS Todo backup and others should work fine.

You need to make a system repair disk (just type that into the start button run bar and follow the wizard) to fix the boot loader drive sometimes when you restart with a cloned drive.

Also, clone the SRP first, and then the OS drive (usually C).
m
0
l
October 18, 2012 10:02:31 PM

My main system went from 2 10,000 RPM 74 GB Raptors to 1 120GB Solid 3. I had to first shrink the partition, but I used Apricorn's adaptor and utility (only cost me $20) and it works. Not my favorite choice, but I didn't have all my SN to my software, so had no choice...
m
0
l
Related resources
October 18, 2012 11:44:38 PM

thanks. you guys at least give me faith.
For my MoBo I have my sata controller set for RAID. Did you guys leave it as RAID or were you able to switch t AHCI and get it to boot?
m
0
l
a c 324 G Storage
October 19, 2012 12:06:52 AM

You can leave it set to RAID -- AHCI is just a subset of RAID and as long as the SSD is not actually in a RAID array the TRIM commands will get passed to the drive without any special efforts.
m
0
l
October 19, 2012 12:29:42 AM

I cloned over the RAID to the SSD with EzGigIV (hoping the new version might work better).
All I get now is the dreaded "reboot and select proper boot device"...
It frustrates me because any of the methods I've tried should have worked and none of them have.
Windows Recovery doesn't see the operating system, and If i choose repair, it just tells me that it can't repair automatically. blah

**edit.
I also just tried using True Image to 'Add new disk to system' then recovering just the main partition from my backup. now I get BOOTMGR is missing.. the fun continues
**
now I can't get past "reboot and select proper boot device" even when I plug my RAID back in..not good
m
0
l
a c 324 G Storage
October 19, 2012 1:56:14 AM

So did you clone the SRP first the the OS drive, and did you make the system repair disk CD and boot up with it in the CD/DVD drive?
m
0
l
October 19, 2012 2:24:30 AM

thanks for the follow up.

not sure what you mean by SRP. I only have one partition on my RAID disk. I assumed you meant system recovery partition, which I don't have. I did make the repair disk and boot to it, it told me to jump in a lake. Ok not really, but it did tell me that there were errors it could not fix.
i was stuck at the "reboot and select proper boot device". I plugged my RAID back in and got same message, even restored my backup over my RAID (scary since it was my only working device) and got same message. After the solution here: http://www.sevenforums.com/crashes-debugging/126363-wei... I at least have my RAID back on so I can get into Windows again.

I moved my swap file to my SSD I use for scratch disk. Would that matter at all?

Interesting factoid... even though Apricorn and Acronis clone disk features say that it will automatically shrink the partition, I decided to go ahead and try to manually shrink it first. However even though I'm only using about 80gb on my RAID, it says the smallest I can shrink the partition to is 168858 MB. Which wouldn't fit on the 120gb SSD anyways...hmmm. I don't think that should matter as there is room on the SSD, but just thought I'd through that out there.
m
0
l
October 19, 2012 4:18:37 AM

wow. looks like a miracle happened. Once I got my RAID to come up after the "reboot and select proper boot device" issue. I thought that maybe if I could get my SSD to that same issue I can fix it.
So I booted to Acronis recovered my main partition.
then booted to Acronis again and recovered my MBR.
Restarted and got "reboot and select proper boot device".
Loaded to DISKPART (had to load my RAID drivers to see the disk). set the correct partition as active.
restarted into System Recovery (loaded drivers again) this time it now saw my OS.
used the auto repair and Windows loads....

wow. what a mess.
m
0
l
October 19, 2012 1:59:53 PM

Not so fast. I now get the "reboot and select proper boot device" on every restart. Every time I restart I have to go to recovery console, load drivers, and let it repair the startup. any ideas?

**update. as long as i have the Windows disk in when i boot, it boots fine even without going to the recovery console. Just boots like normal.
SSD is in first boot order and DVD drive in second.
m
0
l
a c 324 G Storage
October 19, 2012 4:29:01 PM

Windows 7 has a hidden 100mb system reserved partition where all the boot information is kept -- the SRP. You need to show hidden partitions and clone it ahead of the system image. Once you have an SRP on the SSD and properly boot you won't need that system repair disk again until you swap out another clone or have some other issue to repair.

m
0
l
October 19, 2012 8:08:58 PM

thanks.
it seems though that I don't see a SRP on my current disk or from the backup. Something screwy seems to be going on.
Options:
1) can I create a SRP from scratch? I tried following these instructions to create a SRP http://www.sevenforums.com/tutorials/119151-system-rese... . However even after running through system repair several times it still will not boot without the Win CD.

2) can I backup my current main partition, install a fresh copy of windows to establish the SRP, then just recover backup over the main partition?

thanks.
m
0
l
a c 324 G Storage
October 19, 2012 10:54:01 PM

Yes, you can create an SRP partition by either unallocating enough space (>100mb -- some recommend 200mb) and creating a new primary partition as 7Forums details, or by unallocating your entire SSD (and I would probably even run a secure erase to start clean) and then creating two new primary partitions -- you just need to have it on the SSD or on another drive, although on the SSD is greatly preferred.

You can also clone your original SRP from the RAID 0 array to the SSD unless you have already reformatted the drives.

Make sure that both are primary partitions, the SRP is marked as the boot partition, and that the SRP does not have a drive letter while the OS is drive C.
m
0
l
October 21, 2012 4:57:15 AM


Ok I quit. I throw in the towel. It wins.. the computer is smarter...

I realized that my backup I had with Acronis did not include the SRP. However I had already restored that backup on my RAID, which is why my RAID was now requiring the disk as well.

I had already tried the method that I linked to at 7Forums to build the SRP before I posted last time. However I tried again with no luck.

So I decided to to a clean all, and installed a fresh copy of windows and allowed it to build the SRP. I then recovered my backup on top of the c: partition on the fresh cop of windows. So now I have the SRP built by Windows and my C: partition.

However I still get missing BOOTMGR. and again, as long as I have the Windows CD in the drive, even if I don't boot to it at all, Windows starts up fine.

I've tried the solution here: http://www.sevenforums.com/tutorials/104341-bootmgr-mis...
Quote:
Click on Command Prompt.

A) Type c: and press <Enter>.

Note Note
C:\ is the drive letter where Windows 7 is installed. You may replace it with whatever drive letter you want where you have installed Windows 7.


B) At the C:\ prompt, type cd boot and press <Enter>.

C) At the C:\Boot prompt, type the following commands and press Enter after each command.

Code:

bootrec /FixMbr
bootrec /FixBoot
bootrec /RebuildBcd

Bootmgr is missing - Fix-4.png

D) Now close the command prompt, remove the DVD and reboot your computer.


And every other missing BOOTMGR, boot issue, and more forum, blog, or any article I can find. All with the same result.
At this point it's just not worth the battle (unless you guys have one last big hoorahh). I can just start double checking all my preferences for everything is saved, and take a day or two and just reinstall a fresh copy of everything when I get the chance (which will be like Janurary :/  ).
Live and Learn. Thanks for the help.



m
0
l

Best solution

a c 324 G Storage
October 21, 2012 1:57:53 PM

One of the reasons that I generally prefer a clean reinstall.

If you don't have time for that, do a repair installation of Windows 7 with only the SSD attached, which saves your data and programs (although you should do a backup first just in case) -- the only thing that you have to reload is all the Windows updates.
Share
October 31, 2012 12:07:43 PM

Best answer selected by buckeye_fan.
m
0
l
!