Sign in with
Sign up | Sign in
Your question
Solved

GTX 470, textures, and PhysX?

Last response: in Graphics & Displays
Share
June 24, 2010 4:24:53 PM

I just had my old Radeon 4870X2 go bad last week, and it won't be covered under warranty for various reasons. So, I got myself a new GTX 470. I had planned on getting a second one, and while the GTX 470 matches performance with the 5850, when there are 2 cards, it vastly outruns the 5850. So I went with the Nvidia card.

I got it yesterday, and I got it installed, but I have had a heck of a time with it.

First off, the texture quality has some issues. Some of the textures in World of Warcraft, specifically bushes, trees, columns, and flags, at a distance are crawling as I move around. The flags are doing this odd thing where they will alternate between showing up and just displaying whats behind the flag. My Radeon never did this. This is very distracting. Anyone know the setting to adjust to try to reduce or eliminate this?

Also, I have been unable to enable PhysX. It might be remnants of the ATI driver holding it back, or it could be my little Lilliput 7" USB monitor. Has anyone had problems like this?

other stats:
Core i7 920 (OC to 3.5GHz at stock voltage)
Asus P6T motherboard
6GB DDR3-1333 memory
HT Omega Striker 7.1 audio card
OCZ Vertex main drive
2X 750GB (RAID 0) WD drives for storage
1X 1TB external eSATA Seagate drive for backup
24" Dell 2407WFP monitor
7" Lilliput USB monitor (for voltage/temp/fan/cpu monitoring software and other gadgets. It's nice to see some things while the main screen is used exclusively for gaming. useful for troubleshooting, too.)
Windows 7 Ultimate 64-bit

Thanks in advance for the help.

More about : gtx 470 textures physx

June 24, 2010 5:02:51 PM

To get rid of ATI drivers, download Driver Sweeper from Guru3d, install it, uninstall ATI drivers via Control Panel, boot into safe mode, run Driver Sweeper and remove ATI drivers, reboot into regular mode, install newest nvidia drivers.
m
0
l
June 24, 2010 5:10:19 PM

I already did the regular uninstall on the ATI drivers and manually removed some of the registry entries and left over folders. (There weren't any files left, but I didn't search the whole registry for ATI entries, I just removed all the ATI entries and keys in the \HKLM\Software key.)

I'll run the Driver Sweeper, now that I've found it. (After extensive searching on Google for it, and multiple links to "this software has been removed", I finally found a good link. grrr... is Google getting stupid lately?) I'll see what I find after that.
m
0
l
Related resources
June 24, 2010 9:15:43 PM

Anyone know what to adjust on the settings to stop the texture crawling?
m
0
l

Best solution

a c 171 Î Nvidia
June 25, 2010 3:51:21 AM

Have you tried setting the negative LOD bias to clamp?
Share
June 25, 2010 9:10:23 AM

Yeah iv noticed the exact same problem when playing modern warfare 2.

A chair leg or a wooden beam across a wall would appear or disappear depending on the angle, so a slight shift to the right and a texture would vanish and move back left and it appears back on the screen.
I agree that it is annoying, especially in fps games as you tend to shoot at the slightest of movements.

I too had a 4870 and did not have such problems, and yes i used driver sweeper in safe mode and removed previous drivers.

Im assuming that it is a driver problem and should soon be fixed.

I will try what mousemonkey said, but doesnt setting negative LOD bias cause the aliasing?

"Applications sometimes use negative LOD bias to sharpen texture filtering. This sharpens the stationary image but introduces aliasing when the scene is in motion". source nvnews

ps. im kinda glad to know that im not the only one with this issue, i thought i had a defective card.
m
0
l
June 25, 2010 2:07:30 PM

Best answer selected by dgingeri.
m
0
l
June 25, 2010 2:16:51 PM

Negative LOD bias to clamp fixed the crawling textures. Thanks for that. I hadn't even noticed that setting before you mentioned it.

Also, I fixed the PhysX issue. Just reinstalling the drivers after a thorough cleanup didn't help. I had to do this:

uninstall nvidia driver
run driver sweeper
unplug USB monitor
uninstall USB monitor driver
reboot
reinstall nvidia driver (got PhysX at this point)
reinstall USB monitor (PhysX would malfunction at this point)
manually reisntall PhysX from the nvidia driver installation folder (got PhysX working again at this point.)

This is good to remember for people who have this:

http://www.thinkgeek.com/computing/usb-gadgets/c609/

It's a nice little gadget to have, but it shouldn't make PhysX malfunction. Nvidia loses points for this.
m
0
l
a c 171 Î Nvidia
June 25, 2010 2:28:51 PM

I'm glad the LOD bias clamp worked for you, as for the USB monitor messing with the PhysX install they aren't the most widely used peripheral are they? And it is known that you will need to spoof a monitor to get PhysX to work with the GenL patch so it shouldn't be too much of a surprise that the driver might misbehave if it "sees" a monitor it doesn't understand.
m
0
l
!