Sign in with
Sign up | Sign in
Your question

Formatting external drive takes forever!!

Last response: in Storage
Share
October 22, 2012 3:05:49 AM

Hey guys. I am trying to format this external hard drive but it is taking forever even on quick format! Just a little background info first. I got the hard drive from my cousin since he didn't want it. It had maybe 10 songs on it and that is all. I tried to format it and it took too long (I probably just got impatient) so I tried to cancel it and the format would not cancel (keep in mind the drive had no problems I was able to copy and remove files no problem before this). So I unplugged the drive from the USB port, I know, stupid move. I plugged it back in and it was converted to RAW file system. I thought maybe if I performed a low-level format and then tried to "high-level" format it, I could get it back to NTFS. The low-level format took 3 days I believe, and when it was finally finished my external drive wasn't even recognizable -____- I unplugged both the power and the USB from the drive and it was recognizable again. I created a partition using EaseUS with no problem. Then when I went to format the partition (I only created the partition did not format yet), EaseUS hanged at 40%. I was able to cancel it and then try to format it from My Computer, again took very long (keep in mind I clicked "quick format" in both cases). I also tried to format using the command prompt (DISKPART) and every time after I create the partition and I try to format it to NTFS it says the disk is not online, then i type in the "online disk" command and it tells me that the disk is already online. Very confusing.

Also if I require to erase everything off of this drive I have no problem in doing so (as you can see). Any help would be greatly appreciated I want to backup my system to this external drive! Thanks in advance :) 
October 22, 2012 3:57:00 AM

If it's still under warranty, I'd just RMA it. Most HD manufacturers have tools on their site which allow users to look up their warranty status by entering their drive's serial and model number.
October 22, 2012 12:39:14 PM

Unfortunately, its a couple of years old, so I doubt it is :/  and now when I try to format it it says Windows cannot complete the format -__________-
Related resources
October 22, 2012 2:36:19 PM

That's a bummer. You can try using diskpart one more time to just delete all the partitions on the drive (user the override command) and start over. If that doesn't work you may be out of luck. Sorry I don't have better news for you.
October 22, 2012 6:55:58 PM

I let EaseUS run while I was in school and when I came back it said the operation was successful. I went to my computer the drive was still unusable and EaseUS updated the system info and the drive went back from NTFS to Unformatted. If I can get a hold of a sata cable I will try to take out the drive and install it inside my PC maybe the enclosure is having problems I've heard of that happening as well.
October 22, 2012 11:19:18 PM

That's actually a good call. I've seen that happen plenty of times too. I dunno why I didn't catch that; maybe it was too late at night. Keeping my fingers crossed for you!
October 24, 2012 4:12:51 AM

Thanks! Gonna take a while for me to get a hold of a SATA cable :(  anybody else have any ideas to get this drive formatted?
!