Sign in with
Sign up | Sign in
Your question

Help: Chronicles of a cheap FDD update

Last response: in Storage
Share
October 22, 2012 2:20:52 PM

It all started when I ordered a cheap-o, online combo Flash Card Reader + Floppy Disk Drive to update my old ThinkCentre which had a normal, working 3.5 FDD that I use occasionally when I need to track down ancient files.

The drive arrived and I hooked it up. It fried two flash drives. I then got a replacement through Amazon. Hooked that one up. The flash drive worked, showed up with four mapped drive letter in windows, but the floppy drive would not accept a disk - the metal casing was visibly bent and so it wouldn't lock the in position. At some point my a: drive disappeared from the desktop.

At this point, with an extra one of these things sitting on my bench, I decided to take it apart. Turns out, the thing is made by taking a slim, laptop style 3.5 FDD, using a circuit board to remap the 20 pin ribbon header to a standard 34 pin floppy cable. Then they stack a card reader board in the extra space left by the thinner drive. The card reader has a 9 pin usb header, connected to a standard 9 carrier cable.

Well, the problem with the first drive was that the cable was not wired correctly. The top 4 pins were wired one way and the bottom 4 pins were ordered another way... Anyway, I rewired this cable, and put the thing in an HP tower. Both the floppy and the card reader worked. So I pull the "bad floppy" combo drive from my ThinkCentre, and put in the one I just fixed / tested in the HP. Once again, the memory card reader is working, but not the floppy drive. The A: disk is showing up in Windows XP after I restarted the machine, but when I try to click it, the system goes into a "not responding" state, and then issues an error that is either "A: is Unformatted" or "Error reading A:". Device manager shows no errors. So I pull the cheap, unbranded China drive and put in the original FDD, a quality Sony drive that came with the ThinkCentre. But it's not working either. I go into the BIOS, and the floppy is disabled, so I enable it, but it's still not working.

I take my Sony drive, hook it up to my HP, and it's working fine. Reads, writes, formats, etc.

I no longer have PC Dr. to run a diagnostic on my ThinkCentre... Lenovo apparently discontinued it. I can't figure out what happened. Maybe a case of ESD screwing up the floppy controller or the MB? But everything else seems to be working fine... it just doesn't add up.

So here's my ThinkCentre sitting there with an empty 3.5 bay and me scratching my head. :pfff: 

a c 372 G Storage
October 22, 2012 5:19:53 PM

gdeangel said:
Maybe a case of ESD screwing up the floppy controller or the MB?


This seems plausible. I've had onboard ethernet controllers go bad (rest of the board works fine) and had to replace it with an add in ethernet card.

You may have to just get yourself a USB external floppy drive.
m
0
l
a b G Storage
October 22, 2012 5:30:12 PM

Considering they're only $20 a USB drive wouldn't be a bad idea...
m
0
l
Related resources
a c 125 G Storage
October 22, 2012 5:37:15 PM

if the system has a newish version of windows try booting into safe mode and see if there more then one floppy drive installed under system device manager. also in safe mode remove the floppy controller in device mander and reboot. it may be a damaged windows file. if the drive still not working right try buring a cd of hirem boot cd. boot off of the mini xp that on the cd and see if the drive will not work. if it does not check the cables on both ends. make sure there no bent pins and the cables are on the right way. pin one to pin one.
m
0
l
November 3, 2012 2:44:55 PM

Thanks for the suggestions. I took some time away from this little side project and got back at it today.

First, I tested with a new ribbon cable... no effect. I inspected the board header, which is missing pin #3 and so is the drive socket (but it's a different pin, looks like #5) but anyway I read that it's common for one of these ground pins to be left off as a way to key older connecters that would have one of the holes plugged up. I don't think that's the problem, since the drive works on another machine.

I moved on to the safe mode experiment. Deleted the controller in device manager, rebooted, device reloaded with no problem, no conflicts, but still won't read the disk. Going to command mode, it returns the error "Drive could not find the sector requested". Based on what turned up on a search for that error, the only thing that seems to make sense given that the drive & disk both work on two other machines .... is that for some reason this floppy controller on the Thinkcentre is try to read the disk in DD instead of HD format or something like that.

I had some trouble finding the hirem boot cd... there seem to be many sites claiming to be the "official source" but I didn't see one with a simple link to download the ISO. Maybe when I have more time I'll figure that out...

I found two highly technical pages that seem to go about explaining how to potentially run down the issue, which are here mainly in case someone else has a similar floppy dis problems and wants to pursue a solution further:

http://wiki.osdev.org/Floppy_Disk_Controller

and also interesting, although harder for me to follow:

http://www.cs.man.ac.uk/~chl/floppy-muddle.html


As for me, when I was looking around for the extra cable to troubleshoot with, I happened to find a brand new, still in the shipping box, USB floppy that I forgot I had!
m
0
l
!