Sign in with
Sign up | Sign in
Your question

Sapphire 5870 Blank Screen at POST

Last response: in Graphics & Displays
Share
Anonymous
June 26, 2010 7:31:07 PM

Hi,

There is a new PC that randomly boots up. I checked everything and I think this is
Graphics problem.

When I switch ON the PC sometimes it's OK but sometimes it seems that system coming up,
NumLock LED is on. (I can switch Numlock ON/OFF) but there is just a blank black screen during POST and monitor LED is just blinking.

I also test power/RAM/HDD. the mobo is ASUS P6T with latest BIOS version.
Thinking about flashing the VGA Card. But I never did it before. Or it is not matter?

ASUS P6T, i7-920 D0, 3x2GB GEIL 1600 , 2x500 GB WD HDD
Sapphire 5870 1GB
June 27, 2010 6:35:18 AM

What about your PSU? brand? model?
Also, have you tried your card in different PC with high PSU?
m
0
l
Anonymous
June 27, 2010 12:32:20 PM

CORSAIR 650W
Also I've changed it with other PSU like ACBEL 750W and by now the PSU is corsair.

One more thing, I updated Graphics BIOS to the latest version by 'atiflash' and the problem exist yet.
m
0
l
Related resources
June 28, 2010 3:55:12 AM

So, did you try your card in different PC?
m
0
l
Anonymous
June 28, 2010 4:37:10 PM

Yes, the same thing.
and finally I installed 7 x64 with CCC 10.6 for the VGA card.
If it goes on the way that I have explained then I look at the HDD LED, then when seems Windows load completely (while monitor LED is just blinking) suddenly it restarts and system tries for second time to boot and it works!
When Windows starts again the first thing it says is a problem report....
isn't it a 'EPU' or 'ASUS Express Gate' conflict?
Both systems I tried have EPU chip. One is an AMD base(M4A78T-E On board VGA disabled.) and the other is P6T. I'm really confused!
m
0
l
June 29, 2010 1:28:35 AM

Well, this is a difficult one, the mobo might have a conflict with your card.
So, don't you have a friend PC with different mobo chipset?

Find one and try again your card, if the same problem occur then RMA your card...
m
0
l
Anonymous
July 1, 2010 11:44:58 PM

[SOLVED]
Hi again,
I mark this thread as solved but maybe I am wrong,... anyway here is the story:
Finally I flashed the sapphire 5870 1gb with ASUS BIOS by atiflash.exe.
It worked very good. about 2 days I tested the system . I tested it with furmark for stability.
Max temp was about 83C in a room of 25C. suddenly when I switch monitor cable into the second DVI port I realized that it was not work absolutely, not randomly.
I was very disappointed and my last chance was to flash the card again with no OEM BIOS but with original ATi 5870 BIOS. by now about more than 2 days it is absolutely OK. 2 DVI ports are ok. No more blank screen at POST. I wish it remains good!
Thanks to techpowerup.com
m
0
l
!