Sign in with
Sign up | Sign in
Your question

HDD access problem

Last response: in Motherboards
Share
June 1, 2011 1:46:44 PM

hi guys,

I have a friend's old box with an C2D 2.2 E4500, Mercury PI945GCM mainboard, it has 2gigs of DDR2 667 RAM(2x1), and an 400W OEM PSU and an LG IDE DVD Writer

It came with an Seagate 160GB 7200.10 (SATA) and an SGT 1TB 7200.12 was added a few months back.

The problem is that whenever the files are browsed through in My Computer the system hangs and recovers in a minute or two. Very few times it doesn't recover and it restarts. This issue is more frequent when accessing large files like videos.

Things I have tried so far:
1. formatting the drives and re-installing the OS in either drives.
2. SMART analysis showed me some initial signs of failure like CRC counts, seek time error but nothing alarming. And the health status is a OK.
3. Moreover I plugged them in my system and they run just fine. no issues with large videos, no hangs, etc
4. Since its an old mobo, I changed the jumpers to 1.5 Gbps mode and it resolved a few detection issues during boot. Nothing on the hang issue.
5. There is no IDE/AHCI mode in the BIOS. Four SATA ports are mapped as IDE Channel 1 master, slave and Channel 2 Master, Slave and the Channel 3 for the actual IDE. Switching ports or altering settings in the BIOS doesn't change a thing.
6. Switching PSUs showed no difference again.

There has never been an BSOD or any error thrown by the OS, so I'm guessing the RAM is fine. Should I be running MEMTEST??

I'm guessing the SATA controller is going bad, any idea???

And the system's gpu (7600GS) failed recently. If thats of any use :) 

Thanks :)  :) 

More about : hdd access problem

a b V Motherboard
June 2, 2011 2:15:44 AM

I noticed the same problem on my tower
it only occurs when there are alot of video thumbnails in a folder
try changing to list or detail view
and also try making more folders for videos and redistributing them for example instead of one folder with 200 videos
use 5 folders with 40 videos
Like I said when one folder has too many thumbnails (video especially)
it seems to glitch

I think it is a Windows 7 glitch but I am not sure
Wouldnt be surprised to see a M$ update to fix it one day LOL
m
0
l
June 2, 2011 5:01:36 AM

but the hang occurs irrespective of the file type, it happens even when browsing through other not-so-heavy file types...

The videos have a higher hit rate, thats al :)  :)  thx for the suggestion :) 
m
0
l
Related resources
a b V Motherboard
June 2, 2011 6:37:14 AM

is there many of the other file types with picture thumbnails?
does it occur in the same folders that have many files within them?
m
0
l
a b V Motherboard
June 2, 2011 6:40:42 AM

I am wondering if there is a limit of files in regards of physical size combined with the total quantity of files in a folder

My video file has about 250 videos in it
I had the same problem
I changed the view to <detail> and it went away

It might not be file type but size and quatity of files

See if it happens with large folders

m
0
l
June 2, 2011 7:04:59 AM

Happens some times with simple text or office files too, disabled thumbnail/preview generation , turned off aero, still hangs sometimes
m
0
l
a b V Motherboard
June 2, 2011 8:58:04 AM

Wow I have to think about this one

This only happens with explorer open?

are you doing fresh installs of OS
or using a cloned image?
m
0
l
a b V Motherboard
June 2, 2011 8:58:50 AM

It is 5am where I am at
so I have to go to sleep now
check back later
m
0
l
June 2, 2011 12:36:36 PM

no hurry, pl take ur time :)  :) 

I did fresh installs, different copies... all of which have been tested...

I ran Memtest too, it found nothing

Cables, jumpers, configs, all have been checked.. I'm planning to conclude its the motherboard....
m
0
l
June 2, 2011 4:20:25 PM

The explorer doesn't crash, it hangs... So does any program which tries to access data from the drive.. simple apps like Photo Viewer, WMP...

Like for example if it an average c2d pc takes 2 or 3 seconds to open an image its late but ok, but this one takes like 10 seconds to open a medium-res pic....

The same pic or higher-res opens fine when the drives are in my tower



m
0
l
June 2, 2011 4:41:04 PM

Hi again, I checked the Event Viewer immediately after the hangs...

There are warnings in the Application Section that it is taking longer than usual to retrieve files and that it could be due to faulty Hardware...

Also in the systems section there are Atapi errors with ID 11 which say that the driver detected controller errors...

Like I said before I'm looking to blame the SATA Controller here?/
m
0
l
a b V Motherboard
June 2, 2011 5:01:22 PM

sounds like it
how about updating/reinstalling drivers for Sata controllers from mobo maker
website?
or is it a factory prebuilt?
m
0
l
June 2, 2011 5:09:41 PM

Just updated to the latest drivers... no change....

So pinning it on the controller...
m
0
l
a b V Motherboard
June 2, 2011 5:14:55 PM

Yes I have to agree
I was hoping it wasnt
Well you can sell and reuse parts
or buy a cheap used mobo
Sorry :( 
m
0
l
!