Sign in with
Sign up | Sign in
Your question
Solved

Help!!! Can't update my Dell C521 BIOS. Keeps saying Running On An Unsupported S

Last response: in Motherboards
Share
June 1, 2011 9:08:54 PM

Hello,

I just ordered a AMD Athlon 64 x2 6000+ processor to replace my old 3800+. I know I need a BIOS update cause I have the old version of 1.1.6. The problem is that when i try to update it to 1.1.11 it says running on an unsupported system. I am running Dell OEM Windows 7 Ultimate but the dell bios flash updater says that the system information is unknown. I've tried looking in every forum I could and I still cannot find a way to update my BIOS. I'm literally stuck right now and need help drastically.
a b V Motherboard
June 2, 2011 3:30:16 AM

Probably, what it is saying is that you are trying to run a 16 bit updater (that is probably designed to be run from a bootable DOS floppy) on a 64 bit operating system, which isn't possible. Dell should provide instructions (assuming it is a Dell system).

If it isn't a 16/64 bit problem, then I'd double check that you have a BIOS file for your motherboard.
m
0
l
June 3, 2011 1:34:29 PM

Oh. I don't have a floopy drive on my pc plus when I downloaded it from the Dell support website, I chose the windows vista 64-bit cause there is no option for windows 7. If I find out what kind of motherboard I have, can i just download the BIOS for it or will it have to be from Dell?
m
0
l
Related resources
a b V Motherboard
June 3, 2011 9:48:07 PM

Chances are it is a Dell motherboard.

On re-reading your original post, it seems it may actually be something else. Are you running the updater as administrator (either with UAC disabled from an administrator account, or giving it permission to run)?
m
0
l
June 4, 2011 7:46:54 AM

The only way I can run the program is by an administrator. I get the same results every time. I even tried downgrading to Windows Vista and XP to try it out and still received the same results earlier today. Yes it is a Dell motherboard by the way.
m
0
l
June 5, 2011 1:13:55 AM

Got my processor today and every thing went well so far except one thing. What I have wrong with it now is not even about the BIOS so thanks for the help anyway PreferLinux. I think my graphics card is going bad. My Avermedia HD DVR has been showing up on purplish picture on my PC screen whenever I stream but on my TV its fine. Do I need a new graphics card or is it something else maybe. Any help would be appreciated. If you need any details about my PC, I check the forums hourly so I can reply quickly.
m
0
l

Best solution

a b V Motherboard
June 5, 2011 9:33:33 PM

It is probably a driver issue, so update the drivers for your graphics card and DVR.
Share
June 6, 2011 4:50:18 PM

Ok. it worked out excellent. My graphics card needed an update. Thanx a million PreferLinux.
m
0
l
June 6, 2011 4:50:29 PM

Best answer selected by disciplecrazy.
m
0
l
March 12, 2012 9:52:44 PM

so what happend with the cpu? I'm having the same issue and this was almost gonna solve my issue then u changed the blame to the graphics card lol, how did u get the bios update to work on win 7? please help
m
0
l
!