Sign in with
Sign up | Sign in
Your question

Partitioning Seagate Expansion USB 3TB drive

Last response: in Storage
Share
October 27, 2012 10:34:26 AM

Hello

I bought an Seagate Expansion 3TB USB drive:

http://www.seagate.com/external-hard-drives/desktop-hard-drives/expansion-hard-drive/


My fisrt idea was to get de 3TB HDD into any free SATA internal port on my computer under windows 7. Only after connecting it, I realized that my BIOS was incompatible with drives over 2 TB and it altered my partition table. I only could see and 746 GB partition. :o 

Now, when no working goog, I would want to use this device like originally, in his enclosure as a 3TB USB drive.

I only could format as and 3TB partition connecting to and SATA port on another computer and in linux (Ubuntu), removing the partition table for another one. :pfff: 

I tried:

- GPT drive and 3TB complete partition

- MBR partition and 2 x 1,5 TB partitions

Both methods work in the internal SATA port on the other machine.

The problem is when I put the drive back in his enclosure it go back to an 746GB parition only.

Investigating in google I found this:
askubuntu.com/questions/151687/encrypted-3tb-usb-drive-gpt-guid-shows-wrong-size-in-ubuntu-12-04-64bit

I assume that in normals USB enclosures it can be, but in this one, sized originally in 3TB, it can't be the problem.


My questinos:
- ¿How can I fix the partition table to get 3TB in usb enclosure?
- ¿What type of partition have to be? MBR, GPT? another one?

thanks in advance to you
October 27, 2012 12:33:20 PM

The problem is related to the Bios chip of the mother board.
Have you tried looking for a bios update file to flash the bios to a more updated version.
I would look that up just to check if there is a bios update to support a 3TB drive size.
October 27, 2012 5:25:48 PM

hello and thank for posting....

in the first computer i couldn't us it as internal drive because the bios is too old (1997) and there is no update available that add this capabilitt.

in the second one, there is no bios limitation because it worked with 3tb size as internal sata drive. i could rewrite the partition table and do another new gpd table with. a linux live cd with gparted.

the really problem is that the usb enclosure don't detect the neither gpd or mbr partitions (divided in 2x1,5 tb) and uses it, connected to the second computer, as an 746 gb drive.

it seems that the usb enclosure unit can't detect the 3 tb partition table and do the same that would do an old bios (746 gb). but the drive originally had 3 tb...ten it have to support in any way this size fo the disk.
Related resources
October 27, 2012 7:50:35 PM

sorru...i posted incompletely..

then...if the drive had 3 tb originally, the usb original enclosure have to detect the correct size....but i suppose that have to be formated in an special way...can be this??

a solution could be delete completely the partition table of the drive with zeroes (if dd /dev/zero ....) and try to create a new one with windows trought usb??

there is a solution???

again, thanks!!
October 29, 2012 12:35:41 PM

up??
!