Sign in with
Sign up | Sign in
Your question

2x1gb Crucial Ballistix in ASRock 4coredual-sata2 r2.0 will not POST

Last response: in Memory
Share
June 4, 2011 8:58:37 PM

Hello everyone, once again I come here for some opinions.

I've been fighting to get a pair of 1GB Crucial Ballistix sticks to work in the 4coredual-sata2 board. The board previously housed 2x1GB Kingston PC2-4200 RAM and worked fine. I've swapped the Kingston sticks with the Ballistix to my main machine because of the 2 kits (4 sticks total) of Ballistix, two have become pretty unstable and the PC won't complete POST with them in.

So, onto the two "healthy" Ballistix modules. Let's call them sticks 3 and 4 (as that's what I've labelled them physically with tape). ASRock mobo PC boots with no issues with stick 3, memtest86 does 20+ passes, prime95 stress passes for 12+ hours. Stick 4 will begin POST, but will not complete it. The PC halts at:

  1. Press F2 to run Setup
  2. Press F11 for Boot Menu
  3. Single-Channel Memory Mode


Putting in both sticks (3, 4) I get a similar incomplete POST:

  1. Press F2 to run Setup
  2. Press F11 for Boot Menu
  3. Dual-Channel Memory Mode


So, task #1 is to get stick 4 to complete POST. This is where I'm stuck, I've tried playing around with the settings in BIOS; unfortunately ASRock doesn't give you the fine controls I'm used to in Gigabyte or MSI boards when it comes to FSB sync or voltage (though the RAM timings are all adjustable!), so I'm stuck adjusting the following:

  1. DRAM Frequency: [Auto, 266MHz (DDRII533), 333MHz (DDRII667)]
  2. DRAM Voltage: [Auto, High, Normal, Low]


I should mention, this PC I'm using as an HTPC is running an E5200 at stock (200MHz x 12.5 = 2500MHz).
I can post more available BIOS settings, if need be, but any suggestions are appreciated. I have tested stick 4 in the other PC with memtest86 and prime95 and it seems to run OK in the GA-P35-DS3R board I have here.

Thanks.
a b } Memory
June 4, 2011 9:34:09 PM

Are those 1.8v dimms? Is that what you have them running at?

I can tell you I had the Ballistix Tracer PC2-6400 and they were total garbage. I had to RMA mine TWICE. 3 of the 4 sticks failed at some point, some of them twice. After the second time I got them back, I sold them on ebay and bought myself some Corsair XMS. Never had a problem again, so now I only use Corsair or Kingston. Both have been very good to me. For flash memory I only buy Kingston.
June 4, 2011 10:15:32 PM

I suppose I should have mentioned the part number of the Ballistix: BL12864AA804
These are 2 x 2x1gb kits. More importantly they are specced to run at 1.8-2.0V (JEDEC - Crucial), I'm not sure if ASRock's "high" voltage setting is 2.0 or less, which is actually part of the reason I'm seeking some help.

I agree with you about the Crucial RAM, but I just sent away a pair of OCZ sticks with the same problem, and I've had issues with both Corsair and Kingston before (both DDR however), so I wouldn't say 1 brand is enormously better than the other.

Besides, I'm in the process of building a system around the i5-2500k so I'm just trying to salvage my DDR2/Core2 pieces :D 
June 9, 2011 2:11:44 AM

New developments:
Flashed the board with custom BIOS 2.20a.
Board boots with stick 3+4, just stick 3, or just stick 4.
In both cases where stick 4 is present, it only registers for half of its capacity (512MB).
Memtest86 fails immediately with 3+4 dual channel config.
Memtest86 is currently running strong with just stick 4 in with 4 passes completed.
Any configuration involving stick 4 will not boot into Windows -- the screen goes blank, and the OS stops loading just before the Windows logo. During this the machine is responsive -- to the extent that pressing NumLock/ScrollLock/CapsLock changes the corresponding keyboard LEDs.

Testing will continue before I RMA all the sticks.
!