Sign in with
Sign up | Sign in
Your question
Solved

Are External Drives Affected by Write Permissions?

Last response: in Storage
Share
October 27, 2012 8:01:50 PM

I was wondering, if I get a flash drive or external hard drive, will it be affected by the write permissions, preventing me from running games from it? The computers I use usually have write permissions disabled on all the drives and folders I've checked, and I was trying to use a portable version of Steam through Cameyo, which is a portable application program, and it is blocked by write permissions. So, if I used an external hard drive, just assuming these computers are extremely strict, would I be able to use it and not be prevented by the write permissions? I know this depends on the circumstances of the PC, but basically, is there a way that the computers could have a blacklist or a whitelist on write permissions? Part of the PCs use Windows 7, and the others use XP. Thanks.

Best solution

a c 317 G Storage
October 27, 2012 11:31:50 PM

Yes, particularly in Windows 7 external write permissions are often disabled. While you may or may not encounter the problem it isn't really a big deal if you do.

There are two basic ways to fix the issue:

Login as an administrator on the computer. Open regedit.exe by typing that in the start search box. Navigate to this key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
You might need to create the key StorageDevicePolicies if it does not exist yet.
Select the StorageDevicePolicies key with a right-click into the right window.
Select New > Dword (32-bit) Value from the menu and name the new entry WriteProtect.
Double-click the new WriteProtect key and change the value to 0. If you want it to be read only you can change it back to a value of 1.
Save the key changes by clicking OK after each.
Restart your computer and then attach and test the USB device.

There is one other thing that I use if that fails in Windows 7 (older versions use a different syntax), and it has always worked. Plug the device in, perhaps into a different USB port, then use diskpart to change its attributes:

Open the command prompt box with right click and run as administrator

Type each of these commands one at a time in this order:
diskpart
list volume
select volume n (where n = the problem volume)
attributes disk clear readonly
attributes volume clear readonly

After each of the last two you should get a response that it was successful.
Share
October 28, 2012 12:32:22 PM

Awesome thanks.
m
0
l
October 28, 2012 12:37:00 PM

Best answer selected by Dog G6.
m
0
l
!