Sign in with
Sign up | Sign in
Your question

Iomega LDHD-UP2 - Spins and Gives Up

Last response: in Storage
Share
October 28, 2012 11:50:35 AM

Hi,

I have a pretty new iomega LDHD-UP2 external hard drive with very few hours on it that stopped working properly.

The only thing that might have happened is physical movement / vibrations. It wasn't dropped or banged hard or anything, but it certainly wasn't overvolted or anything like that.

I believe it is a 2TB hard drive if I remember correctly.

When I hook it up, I can hear it spinning for a second or two and then quitting, as though it hasn't found the next step of recognition to keep going. It makes maybe half a dozen attempts and then just says "screw it" and goes silent.

I removed it from its enclosure and plugged it into an Aluratek docking station. When I turned it on, it does the exact same thing.

Any ideas / solutions?

Thanks for your time.

More about : iomega ldhd up2 spins

December 5, 2012 11:57:37 AM

I have a similar problem. My iOmega LDHD-UP2, 2TB, External Hard Drive works fine when I plug it in and the files (mainly videos) run properly. I have divided my 2TB into two partitions (lets say U drive & ME drive), nearly 1TB each. Both the partition is formatted as NTFS.

The problem is that the ME drive that has all videos, about 10GB, does not copy files properly anymore. Any file size over 500MB will start copying and eventually the copying speed rate decreases dramatically, most of the times from 100MB/s to 2MB/s, and just stops without moving any further when its about 10 - 20 sec left to complete the transfer of data (videos). I have tried waiting for the completion of data transfer for more than 5 hours for just 1.5GB File.

The light on the External Hard Drive blinks very fast and stops blinking randomly when the transfer stops/ freezes.

To fix this problem I have tried Defragmentation of the ME drive, tried USB Update, tired Error-checking, virus scan for both the drives (U & ME) and also recently copied all my 10GB worth or data on to my desktop, formatted the ME drive again with NTFS and copied back all the files. It was working fine until i copied all the files but then soon after a day passed by the same problem occurred in the ME drive.

Since the transfer of data stops, I try to cancel the transfer, its loads for 2+ hours and does not close/ cancel. This leads me to unplug the USB from my computer without ejecting the drive.

Meanwhile the U drive with just about 5GB of data works perfectly fine when copying big media files

Is it because of the space used? even then i have about 980GB of free space on my ME drive!

So please if anyone had any solutions or suggestions for my problems I'll be so thankful for you...
m
0
l
Related resources
!