Sign in with
Sign up | Sign in
Your question

EVGA nForce 680i Sound Problems

Last response: in Motherboards
Share
June 5, 2011 10:56:57 PM

I just recently got an EVGA 560 Ti Crysis 2 edition video card and a H70 CPU Cooler and installed it with no issues other than having to mount my 200mm big boy fan on the outside of my P190 Case. So everything boots up and I decide to OC my chip (e6750) to 3.4GHz stable. After that, now mind you I did a fresh install of Win 7 64bit before I did all this so everything is nice and clean and stuff. I notice that I don't have sound anymore from my x-fi card, so I try my onboard sound and that doesn't work either. I re-seated my x-fi card in multiple PCI slots but for some reason the computer wont recognize it. When I plug my plugs into the motherboard audio jacks it still says speakers are unplugged and it wants to use Realtek Digital Out. I tried installing the x-fi drivers but it gives me an error saying it cant install because it doesn't detect my card. Does anyone have a fix to either get my onboard audio working or the card audio working? Thanks!!
a b V Motherboard
June 6, 2011 12:45:39 AM

The video card may be causing this. I've come across cases in which cards like this which have an audio codec and audio out through HDMI can "hijack" the onboard audio control. You should be able to fix it by making a change in the BIOS: if your onboard sound setting is set to AUTO, change it to ENABLED and re-start.
m
0
l
June 6, 2011 1:59:46 AM

Nope I have only 2 options in the BIOS, its Auto or Disabled (HD Audio) and Windows won't even recognize my sound card. I tried both disabled and Auto, and also disabled the nvidia audio codecs via device manager as well. Still only give me 2 options...



Yes the plugs are plugged in and the unit is on (I got the Logitech 5.1 surround system from 2008)
m
0
l
Related resources
a b V Motherboard
March 15, 2013 6:19:38 PM

test

happy picture

m
0
l
a c 180 V Motherboard
March 15, 2013 7:14:20 PM

Test as well.
m
0
l
March 16, 2013 10:24:30 AM

My problem was exactly as described above, Speaker in the Playback tab of Sounds control panel was not selectable, with a red check-mark. Realtek Digital Output was selected as the default Playback device, but no sound at all from my system.

The Win7/64-bit audio driver from the EVGA site installed the Realtek driver with a Control Panel item:

Realtek HD Audio Manager

While fiddling with the settings there, I noticed a small yellow folder icon in the upper right. Clicking on that shows this option:

Disable front panel jack detection

It was unchecked. When I checked it and clicked OK, voila! A Speaker tab showed up in the Realtek manager, AND the Speakers icon in the Window Sounds now has a green check-mark.
This must be a bug in the Realtek driver version from EVGA. I thought about getting the drivers from Realtek, but won't bother now that my sound is working.



Sam
m
0
l
!