Sign in with
Sign up | Sign in
Your question

USB Flash Drive is write protected and shows up as unknown on Disk Management. H

Last response: in Storage
Share
October 28, 2012 6:32:52 PM

Hello,
I purchased a 64gb Centon DataStick Sport. I received an error message saying that it is write protected about halfway into a data transfer. It does not show up under My Computer but when I go to disk management it shows up as USB Mass Storage Device under Disk 1, unknown, 59.8 GB, Not intialized. There is no drive letter. I tried using "cmd"->diskpart->list disk->select disk 1->clean but that didn't work. When I used select disk 1->detail disk, it would crash. When I entered clean all, it would bring up that it was write protected. Today was the first time I've ever used the cmd prompt so I'm unsure of what to do next. I can't format it using format e: because there's no drive letter assigned.
a c 324 G Storage
October 28, 2012 8:53:16 PM

Turn off the write protection using diskpart, as I detailed here: http://www.tomshardware.com/forum/291901-32-external-dr...

diskpart
list volume
select volume n (where n = the problem volume)
attributes disk clear readonly
attributes volume clear readonly

After each of the last two you should get a response that it was successful if it was.
m
0
l
October 29, 2012 11:55:35 PM

RealBeast said:
Turn off the write protection using diskpart, as I detailed here: http://www.tomshardware.com/forum/291901-32-external-dr...

diskpart
list volume
select volume n (where n = the problem volume)
attributes disk clear readonly
attributes volume clear readonly

After each of the last two you should get a response that it was successful if it was.


The issue is that the volume doesn't even show up, but it shows up under the disk manager.
m
0
l
Related resources
October 30, 2012 12:05:47 AM



here's a cropped screen shot of what I'm seeing
m
0
l
a c 324 G Storage
October 30, 2012 12:06:38 AM

jinthesensei said:
The issue is that the volume doesn't even show up, but it shows up under the disk manager.
Your original post indicated that the device showed up with a diskpart command. Is that not the case?

Okay, with your last post, I see that it does show up -- don't try the clean command, use the clear commands that I listed to remove the protection first:

diskpart
list volume
select disk 1
attributes disk clear readonly
attributes volume clear readonly
m
0
l
a c 324 G Storage
October 30, 2012 10:27:32 AM

My bad, forgot to add the list volume ahead of the select volume and attributes clear volume readonly -- but it doesn't matter, as I don't think that command runs on flash, only external USB HDDSs.

Are you able to format the device now?
m
0
l
a c 324 G Storage
November 6, 2012 1:59:47 PM

jinthesensei said:
Unfortunately no
The other thing that I usually try in Windows 7 (assuming the drive does not have a physical lock and if a flash drive it is not really old and worn out preventing further writes) is to set the Win 7 registry key to allow writes.

Login as an administrator on the computer. Open regedit.exe by typing that in the start search box. Navigate to this key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
You might need to create the key StorageDevicePolicies if it does not exist yet.
Select the StorageDevicePolicies key with a right-click into the right window.
Select New > Dword (32-bit) Value from the menu and name the new entry WriteProtect.
Double-click the new WriteProtect key and change the value to 0. If you want it to be read only you can change it back to a value of 1.
Save the key changes by clicking OK after each.
Restart your computer and then attach and test the USB device.
m
0
l
November 11, 2012 7:47:14 PM

Followed your directions and set the value on WriteProtect to 0. Still no change.
m
0
l
a c 324 G Storage
November 11, 2012 8:06:48 PM

If you are fluent in Linux, there may be a chance to format using Ubuntu and then reformat it on a Windows PC.

IMO the drive is defective if none of this worked and you should RMA it if still under warranty.
m
0
l
!