Sign in with
Sign up | Sign in
Your question

ATI DRIVER BUG ?

Last response: in Graphics & Displays
Share
July 1, 2010 1:17:50 AM

Just wondering if anyone else is having this problem. In the catalyst control centre if i alter the fullscreen 3d gamma setting it does nothing to brighten up games, it always revets dark and when i exit a game the desktop is dark until i open the conrtol centre and it just goes back bright,
i never had this problem with any older gen ati cards, is this just a new driver bug or HD series cards bug??
any advice is apreciated :D 

More about : ati driver bug

July 1, 2010 6:05:25 AM

Which driver are you using ?
July 1, 2010 9:45:29 PM

Maziar said:
Which driver are you using ?


im currently using the new 10.6 catalyst drvers
Related resources
July 2, 2010 5:27:56 AM

did you click apply?
July 2, 2010 6:54:30 AM

Try testing with older drivers and see if it helps
July 2, 2010 12:24:19 PM

@sabot00 ; yes iv tried apply.

@Maziar ; i shall try some older drivers but i dont want to go to far back as some games may not work or have slow down.

does anyone actually have brightness issues with the latest drivers other than me?
July 2, 2010 12:35:22 PM

pkw4 said:
@sabot00 ; yes iv tried apply.

@Maziar ; i shall try some older drivers but i dont want to go to far back as some games may not work or have slow down.

does anyone actually have brightness issues with the latest drivers other than me?


There have been quite a few issues reported with this driver. Last week sometime they pulled it from the website. Dont know if its back up again or not. Just checked and its back.
Its a bit anoying really considering they have the better tech by far you would think they would worry more about Quality and less about speed. Then again i did hear this driver was rushed to combat the Nvidia cards. I read that the 470 was faster than the 5850 but isnt now after these Drivers.
Didnt bother to check it out just what i read and heard. Edit because i put an extra 7 in the 470 :) 

Mactronix
July 2, 2010 12:40:29 PM

im using a 2900xt, i would have thought they'd have the drivers perfected for this old card by now. everything is fine but brightness/gamma in full screen 3d, it just does'nt work at all.
July 2, 2010 12:46:57 PM

That's probably your problem to be honest, using a 2900XT i mean. After a while it gets to be pointless upgrading your drivers with older cards. With my 3850 i stopped after about 8.6 i think, from memory.
They concentrate on performance with the newer architecture and games much more than they worry about maybe breaking something for the older cards. If they get enough feedback they will put a fix in if not then its all good.
I would just go back to an older driver. Unless they specifically implement something in the drivers that you would benefit from then there is no point in keeping drivers upto date with older hardware. A bit like Bios updating really. If it doesn't 100% need it don't do it.

Mactronix

July 2, 2010 1:01:46 PM

it may be an old card but it still crunches out reasonable frame rates, i dont fancy upgrading because ati has left this card behind in driver support. are there any programs that could force my brightness settings?
this card gives me 47fps avrg (39fps min) in dirt 2 with high settings @12x10, i use 12x10 as my gaming res as im using a 21" crt and that seems the ideal res for this card.
!