Sign in with
Sign up | Sign in
Your question

I can't access ONE folder in my external hard drive

Last response: in Storage
Share
October 30, 2012 8:18:00 PM

Hello,
I have a 2TB Western Digital My Book Essential External Hard Drive. One day when i tried to access a subfolder in one of my main folders it asks me to format the hard drive. It was working fine previously and I can access all other subfolders. I tried to search up solutions but got really confused as to how to work with them and now when i try to access the main folder, the message asking me to format my hard drive comes up. I can still access other main folders no problem. I have childhood videos and photos saved in there so if possible I really do not want to risk losing the files by reformatting. But I cannot gain access to it. Can someone please help me out?

I tried to use Testdisk but I have no idea how to use that program and it keeps freezing on me
November 11, 2012 12:16:35 PM

thank you to both! I've backed up all my other data and is currently in the process of finding a good data recovery program. I hope it will be able to get my files back
m
1
l
!