Asus P8P67 (new p67b3 revision) crossfirex

Hi, I have installed 2 Asus EAH6850 directcu graphics cards into my Asus P8P67 (new p67
b3 revision) motherboard. I have connected all power connections (2 per card) and installed one of the supplied Crossfire bridges.
On booting, both cards appear in my device manager, which says that they are working properly. However I do not appear to be able to enable Crossfire mode (which should be an option in the Catalyst Control Centre). I thought it may have been a driver error, so I have uninstalled the drivers which came with the cards and installed the latest ones from the Asus site, all to no avail.
I have even reinstalled Windows and made these latest drivers the first thing I installed but I still can't get it to work.
Any help would be appreciated.
Thanks
2 answers Last reply
More about asus p8p67 p67b3 revision crossfirex
  1. I recommend you go into the P8P67 bios and set the PCIe bandwidth for the second card at x4 rather than whatever the default is. Does that do the job?
  2. The specs page for that board says the second (black) slot defaults to x1 mode "for system resource optimization." As fullofzen states, there is probably a BIOS option to turn it up to x4. If not, it may do x4 automatically if it detects a graphics card installed.

    bluefin:
    That particular board isn't the greatest for CrossFire because the second (black) slot can only do PCIe x4 speed. If you really want to do CrossFire and get maximum performance from it, I suggest you return that board for refund and get a P8P67 Evo or Pro board instead. That way both cards will match at x8 speed.
Ask a new question

Read More

Asus Graphics Cards Motherboards