Sign in with
Sign up | Sign in
Your question

HD5770 400/900 Mhz ?

Last response: in Graphics & Displays
Share
July 2, 2010 3:52:07 PM

I have a question , i used to have an ASUS HD5770 but it was VERY noisy and i changed it to Sapphire
With Asus i in Battlefield Bad Company 2 with 1920x1080 and all full graphics 8xAA 16xAF DX11 i had like ~30 fps , now with my Sapphire i have like ~20 fps with DX10 4xAA 8xAF , with DX11 is ~15-18fps , and what is strange , current values which shows ATI Overdrive GPU clock 400 MHz and Memory 900 MHz , i wanted to check it during the game , i opened MSI Afterburner and it showed me the same 400 MHz and 900MHz , EVGA Precision showed the same , with and without stress its 400/900 MHz , why??
I tried to OC but numbers do not change
CPU: e7500@3.6GHz
MB: ASRock P5B Pro
Ram :4GB DDR2 Corsair (800MHz)

I tried 2 versions of drivers , 10.5 and 10.6
Maybe to try to put other drivers>?

More about : hd5770 400 900 mhz

July 2, 2010 4:04:30 PM

try other drivers too.. don't forget to use driver sweeper before changing the driver
July 2, 2010 4:15:46 PM

oh , dont know why but now it shows 600 MHz / 1200 MHz , if I OC only the Memory increase , the GPU Clock is 600 stll
P.S. i havent done anything , just reentered the game)
July 4, 2010 7:39:06 PM

I have the same problem, except I have a 5750 vapor-x bios flashed to a 5770 but I have it OC'd to 950/1350 and when O game it will only go to 600/1200 and I have no idea why. If I figure it out I'll let you know.
July 6, 2010 8:25:18 PM

I don't know if it will help you but when I flashed my card it screwed up my powerplay profile so I flashed it back to the original bios and now it works fine.
July 8, 2010 10:23:07 PM

so what should i do?? install another bios? where can i find it?
July 9, 2010 10:01:10 AM

" ...so what should i do?? install another bios? where can i find it?..."


You should start from scratch.

Follow the procedure below to get completely rid of previous drivers, settings and messed-up profiles:

Disable (uncheck if it is checked) OverDrive in CCC OverDrive section and click apply.

Close CCC.

Uninstall Ati install utility in Programs in Control Panel.

Restart your computer.

Open Registry Editor.

Please do note: If you delete a wrong key in Registry Editor, your computer may become erratic. Do whatever you do at your own risk.

Delete HKCU\Software\Ati key

Delete HKCU\Software\Ati Technology key

Delete HKLM\Software\Ati key

Delete HKLM\Software\Ati Technology key

Delete HKLM\System\CurrentControlSet\Services\Ati-related keys

Delete everything in C:\Users\{your user name}\AppData\Local\Ati\Ace folder. This folder contains Ati default profiles and your messed-up profiles.

Open Device Manager.

Remove Ati Radeon 57xx series card under Display Adapter.

Restart your computer.

Now you can re-install the latest gfx card drivers from AMD.

Whenever I install a new version of CCC every month, I follow this tedious procedure.
July 9, 2010 2:23:54 PM

Hey , thx for reply , but i cant find HKCU\Software\Ati key ,HKCU\Software\Ati Technology key
,HKLM\Software\Ati key ,HKLM\Software\Ati Technology key ,HKLM\System\CurrentControlSet\Services\Ati-related keys , post some screens PLZ
July 9, 2010 3:31:38 PM

If you cannot find them, your CCC installation is very corrupt or you do not know what HKLM and HKCU mean. Then you should not touch registry.
July 9, 2010 3:42:13 PM

yeah i do not know what does it mean , but please help , for ex in Registry Editor i go to \CurrentControlSet\Services , and there is no Ati-related keys , hmm , maybe reinstallis OS will help , but i dont wanna do this , so i need some help plz
July 9, 2010 4:38:50 PM

HKLM is HKEY_LOCAL_MACHINE and HKCU is HKEY_CURRENT_USER.

But again, if you have never used the Registry Editor before, I suggest you either get help from a knowlegeable friend or keep away from Registry Editor.

If you do not see anything related to Ati, you may have corrupt installation of Ati driver as these registry keys contain settings to the gfx card.
July 9, 2010 4:53:50 PM

Further to my post above, in my Win7 x64 computer, there are 4 keys under

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\

amdkmdag

amdkmdap

Atierecord

AtiHdmiService

You should delete them all. These keys are valid for CCC 10.6.
July 9, 2010 5:46:21 PM

I deleted this 4 , Deleted ATI drivers , deleted once more with Drive Sweeper , restarted and installed Catalyst 10.6 , and nothing changed , as before in 3D aps it uses 500mhz/1200 , if i OC the Core Clock it becomes 600MHz , but in Registry Editor i saw files ; amdgap , amdide , AmdK8 , AmdPPM, amdsata , amdsbs , amdxata ; Should i delete them too?
And yeah i forgot about
"Delete everything in C:\Users\{your user name}\AppData\Local\Ati\Ace folder. This folder contains Ati default profiles and your messed-up profiles.

Open Device Manager.

Remove Ati Radeon 57xx series card under Display Adapter.

Restart your computer.

Now you can re-install the latest gfx card drivers from AMD.

Whenever I install a new version of CCC every month, I follow this tedious procedure. "
July 9, 2010 7:40:58 PM

No, you should not delete them. They are not for Ati gfx card drivers. They are some other Windows drivers.

Just delete profiles ( they are in hidden folders. You should enable Show hidden folders. ) and remove Ati Radeon 5xxx card in Device Manager and restart computer.

Now you should install the drivers.
July 9, 2010 10:10:37 PM

i did it all , but still it uses 600/1200 mhz , and i dont know why there is no CCC icon on the desktop , for some time ago it automatically opened , but now i cant see it anywhere((
July 9, 2010 10:14:08 PM

and yeah in CCC folder i can open only Basic or Advanced CCC , and i do not see any overdrive here ( before i didnt see any overdrive too , maybe reinstalling OS will help ;(
July 9, 2010 10:48:58 PM

but i dont want this(((
July 11, 2010 7:15:47 AM

Right-click on a blank space on Desktop and a pop-up menu appears.

On top of the menu, you will see Catalyst Control Center.

Click it.

Then Catalyst Control Center window opens.

On the upper left corner of this window, there is a drop-down menu named Graphics. Click on the tiny triangle and you will see the other menus opening downward. OverDrive is the lowest option.
July 11, 2010 10:58:28 AM

yeah , some time before i used to have Overdrive there , but now dont know why i dont have it in the Graphics menu((
Bedore i had a Asus 5770 , maybe its a problem too?
July 13, 2010 2:33:35 PM

Just out of curiosity, have you ever edited your card's bios, and did you buy the card new? Also, what is the exact model of your card?
July 15, 2010 5:49:00 PM

yeas new , ok so i fixed it , the problem was in bios , dont know why but in bios settings Core Clock was 850 , but max Core Clock was 600, i edited it , and now its ok)
July 16, 2010 12:53:27 PM

I figured it had something to do with the bios. That's almost always why powerplay gets messed up. That's very strange that a new card would be like that. If I was you I'd contact their support center and tell them. They might know about it and send you a new bios. That way your warranty won't be shot.
July 16, 2010 1:54:25 PM

How did you fix this in the BIOS? I think I got the same problem... but it's my memory. No matter what I do it's stuck at 1200.
July 16, 2010 2:52:51 PM

One way is to find your bios here and use either atiflash or winflash to flash your card. atiflash is more reliable, but winflash is easier. They should both work. Just a side note, flashing a VGA bios is not like a motherboard bios, if the VGA bios flash is corrupted or doesn't work for some reason you can just reflash it with another bios or the original one. You are not screwed like you are with a mobo. Just in case you should use GPU Z to backup your current bios. Good luck!

http://www.techpowerup.com/vgabios/index.php?page=1&arc...
!