Sign in with
Sign up | Sign in
Your question

At breaking point with this 5970...help?

Last response: in Graphics & Displays
Share
July 3, 2010 1:36:32 PM

Hi again everyone, I have realised through GPU-Z that one of the GPUs in my 5970 is running at idle temps and clock speeds during intense play in Crysis and DIRT 2. After getting low fps in Crysis on very high settings at 1920x1080, I checked GPU-Z.

I recently upgraded to Catalyst 10.6.

Any fixes for manually upping the clock speeds?

Thanks

More about : breaking point 5970

July 3, 2010 1:41:36 PM

Clock speeds are unrelated to your specific problem. It sounds like your card is not enabling its internal crossfire.

Go into your Catalyst Control centre, under the 3D menu, make sure than Catalyst AI is NOT disabled (box will be checked if it is disabled).
July 3, 2010 1:45:53 PM

JofaMang said:
Clock speeds are unrelated to your specific problem. It sounds like your card is not enabling its internal crossfire.

Go into your Catalyst Control centre, under the 3D menu, make sure than Catalyst AI is NOT disabled (box will be checked if it is disabled).


AI is set to "Advanced", and GPU-Z shows that crossfire is enabled.
Related resources
July 3, 2010 1:57:41 PM

If one of your GPUs is staying at idle during gameplay that should utilize both GPUs, then it is simply not being used. Increasing your idle clocks, or disabling the downclocking powersaving features all together will not enable crossfire, just increase your idle temps and power consumption.

Have you tried running some stress tests while monitoring the GPU load/temps? Furmark is one you could try.
July 3, 2010 2:01:01 PM

I'll give that a go. How come gpu-z is showing crossfire being enabled?
July 3, 2010 2:12:13 PM

That is the confusing part. Normally, if GPU-z is showing it enabled, it is.

Has this card been performing this way since you bought it? Did you replace another card, or was this part of a fresh build? If you replace another card, and if it was an Nvidia unit, you may need to run Driver Sweeper in safe mode to completely clean up the old drivers, then reinstall 10.6. Also consider a windows re-install, if only to completely eliminate a possible software issue. If problem persists after windows re-install, then a warranty claim would seem prudent.

At this point I am grasping at straws, though. In my experience owning a 4870x2, if GPU-Z said CF was enabled, I was getting CF performance in games, and GPU-Z was showing load across both GPUs.
July 3, 2010 2:23:50 PM

I have never used an nvidia card, and this build was a fresh install of windows. The card has been like this since I purchased it. I have heard that the card may perform better if it is in the top slot? However, I will try a reinstall, but seeing as the build is only a week old, it doesn't seem necessary.

Anyway, thank you very much. I will run furmark and reinstall, if that does not solve the issue, a replacement will be in order.
July 3, 2010 2:37:54 PM

You have the card in the bottom slot? Yes, try it in the top spot before a reinstall, in case that second slot is limiting you in some way.
July 3, 2010 2:51:54 PM

Also, is it worth overclocking the idle and full load speeds once I get the crossfire working ?
July 3, 2010 8:46:28 PM

Yes. a 5970 is 2x 5870 cores that are clocked down to 5850 speeds. They overclock well, once heat is taken care of, and at 5870 speeds pretty much match 5870 in crossfire. At stock they perform between cf5850 and cf5870.
July 4, 2010 10:25:02 AM

Okay this is weird.

After some extensive testing using Furmark, I can confirm that both cores are being used according to GPU-Z. That was at 1920x1080 resolution 0xAA. They were both running at around 735/1000Mhz.

However in games, only one core is used. This happens in Crysis, Crysis Warhead, and DIRT 2, so it can't be the games..

Why would furmark utilise that core but the games will not? And I ran the games in full screen, just to make sure..
July 4, 2010 11:20:57 AM

Installed it..

Did absolutely nothing. Second core is still running at idle speeds.
July 4, 2010 12:58:22 PM

Any more advice?
July 4, 2010 11:47:59 PM

Could one of the two internal GPUs be malfunctioning?
July 4, 2010 11:50:49 PM

Could you try newer drivers?
July 5, 2010 2:45:15 AM

Userremoved said:
Could you try newer drivers?


I am using 10.5. However, the problem is there with 10.6. I might try going back to 10.4. There is a possibility of a malfunction, but I am going to buy some new games and test the performance, to see whether it is just crysis.
July 5, 2010 12:12:36 PM

What about the new 11.X drivers?
July 5, 2010 12:19:36 PM

Userremoved said:
What about the new 11.X drivers?


Whoa whoa whoa, hold the train, its already 2011?

(BTW, ATI Driver designations are based on the year and month of release, IE: 10.6 is 2010.June)
July 5, 2010 12:33:28 PM

I tough they had beta 11.x drivers out already I guess I it was 10.X beta sorry.
July 5, 2010 8:18:42 PM

Okay, this is unacceptable. Metro 2033 doesn't even have the dx11 options available, Crysis has started to run at about 20 fps. I'm going to switch to 470 GTX SLI. I've had enough with crappy ati drivers.
July 5, 2010 8:33:07 PM

You have a hardware issue. Either your card or your mobo is malfunctioning. If I card fails like yours has since a fresh build and windows installation, then it is very highly unlikely to be a driver issue. Feel free to spend your money however you see fit, but to blame the drivers is erroneous. Bad parts can and do get shipped out (my first 890GPA-UD3h mobo was DOA) whether a bad part from the get go, or shipping damage, it happens. I understand your frustration, but try to understand that there is probably more going on here that just "crappy ati drivers".
July 5, 2010 10:04:51 PM

Mezza_18 said:
Okay, this is unacceptable. Metro 2033 doesn't even have the dx11 options available, Crysis has started to run at about 20 fps. I'm going to switch to 470 GTX SLI. I've had enough with crappy ati drivers.

Like he said it's not the "crappy ATi drivers" but either your motherboard or GPU. Could you RMA both? Also on a side note if you buy two GTX 470s you wont need a heater in your room or a oven.
July 5, 2010 10:17:32 PM

Userremoved said:
Like he said it's not the "crappy ATi drivers" but either your motherboard or GPU. Could you RMA both? Also on a side note if you buy two GTX 470s you wont need a heater in your room or a oven.


Well, considering I'm using a haf 932, and an 850 watt corset power supply, heat isn't going to be an issue. And all I hear are problems about ati drivers, freezing, blue screens, etc. You seem biased toward ATI judging from your post anyway..






July 5, 2010 10:28:26 PM

Mezza_18 said:
Well, considering I'm using a haf 932, and an 850 watt corset power supply, heat isn't going to be an issue. And all I hear are problems about ati drivers, freezing, blue screens, etc. You seem biased toward ATI judging from your post anyway..

Listen I have been using nVidia cards for two generations but the new GTX 4XX is very disappointing. Also what brand is that PSU also they recommend about 1000W
July 5, 2010 10:49:50 PM

Userremoved said:
Listen I have been using nVidia cards for two generations but the new GTX 4XX is very disappointing. Also what brand is that PSU also they recommend about 1000W

I guess its a all or nothing world ? Its not disappointing to me. Most consider this disappointing though.


July 6, 2010 1:40:04 AM

Userremoved said:
What's wrong with your screen did your cards fail?



Yeah, due to whatever, his ATI card as failed. And the recommended psu for 470 SLI is around 650, not 1000.. I have 850 I'll be fine.
July 6, 2010 12:09:50 PM

Ok then! Have you decided which brand are you going to purchase from (Zotac, Asus, Gigabyte, etc.)?

July 6, 2010 3:13:41 PM

Userremoved said:
Ok then! Have you decided which brand are you going to purchase from (Zotac, Asus, Gigabyte, etc.)?


I fixed the problem, I had to update my motherboard BIOS. Games run fine now, except in metro 2033, the dx 11 options are not available? What gives?
July 6, 2010 3:16:23 PM

Mezza_18 said:
I fixed the problem, I had to update my motherboard BIOS. Games run fine now, except in metro 2033, the dx 11 options are not available? What gives?

Metro 2033 was made for nVidia cards so it glitches with ATI cards.
July 6, 2010 3:20:39 PM

Userremoved said:
Metro 2033 was made for nVidia cards so it glitches with ATI cards.

I don't have the answer for him, but there are plenty here with ATI cards running that game in dx11, one fellow with dual 5850's and a dedicated physX card as well.
July 6, 2010 3:23:47 PM

Sorry what I meant was probably a glitch try reinstalling it.
July 6, 2010 3:40:27 PM

notty22 said:
I don't have the answer for him, but there are plenty here with ATI cards running that game in dx11, one fellow with dual 5850's and a dedicated physX card as well.



I can't even enable dx11 in metro, the option is greyed out, I have dx 11 installed though.. Anyway, the performance hit isn't worth the increase in visuals.
July 6, 2010 4:28:14 PM

notty22 said:
I googled the term
can't enable dx11 in metro.
first link is a 7 page thread for a GTX 480, guess your not alone.
http://www.overclock.net/nvidia/710525-cant-enable-dx11...



Haha, thanks, it works now. But I can't really notice any differences.Until developers can fully harness dx 11, it isn't worth the fps drop. Now, if they could patch the horrible hit detection...



!