Sign in with
Sign up | Sign in
Your question
Solved

I didn't install the I/O shield

Last response: in Components
Share
October 18, 2010 4:00:01 PM

This was my 1st build and i forgot to install the shield. I'm worried because something might go into my computer. Is there anyway of putting it in or is there a substitute. The mobo is an asus m4a89gtd

More about : install shield

Best solution

a c 104 ) Power supply
October 18, 2010 4:28:18 PM

Your going to have to remove the mobo again to install the i/o shield correctly in the case,
or you could live without the shield, its up to you tbh
Moto
Share
October 18, 2010 4:44:09 PM

It's a non-issue really. But if you're really worried, follow moto's suggestion, assuming you do have the intended I/O shield.

I suggest not to worry about it too much though, unless you live in a house where cockroaches and mice are large in numbers (to take over the world! :lol: ). Especially when you don't have the required I/O shield.
m
0
l
Related resources
October 18, 2010 4:49:55 PM

Dust might be the only problem, as long as your gentle when adding usb devices or what ever. The shield does add some protection in the way of rigidity for the ports in the back. As said above, nothing to worry about, just keep the computer clean of dust, and be gentle when plugging things in.
m
0
l
a b ) Power supply
October 18, 2010 6:36:17 PM

As above, dust and possible could influence cooling.
m
0
l
a b ) Power supply
October 18, 2010 10:07:59 PM

I ran my last gaming build for 3 years with no sidecover on it at all. Dust wasn't an issue when I tore it apart a fw months ago. I was surprised myself.
m
0
l
a b ) Power supply
October 18, 2010 11:17:06 PM

^ Depends on where you have your PC. My rigs all got dusty a few months after cleaning because they were on carpet. Now my main rig sits on a desk.
m
0
l
October 26, 2010 9:42:26 PM

Best answer selected by PsychoHistory.
m
0
l
a c 104 ) Power supply
October 27, 2010 6:15:41 AM

Thanks for B.a. man, :) 
Moto
m
0
l
!