Sign in with
Sign up | Sign in
Your question

Terrible performance 5770 help please?

Tags:
  • Graphics Cards
  • Performance
  • World Of Warcraft
  • Graphics
Last response: in Graphics & Displays
Share
July 4, 2010 5:03:55 PM

So last week i got a 5770 and my performance was TERRIBLE i get 20 frames on bfbc2 at 1920 resolution (high settings no AA). 13 frames in cities on wow(low) and on trackmania the frames are pretty rank as well. and my screen will flicker sometimes when i'm on my desktop. and it will go black for a second or 2. I've called HIS for help, AMD/ati, and ASUS. I cannot seems to get the performance I should be getting i have tried everything i can possibley think of to fix this issue and nothing is working. I even re-installed windows. Windows 7 64-bit Ultimate. If anyone has any amount of incite I would Be very appreciative. Thank You.

my specs:
HIS iceq Hd 5770 turbo

AMD Phenom 9600 (2.3Ghz)

Motherboard: Asus M4A785-M

3gb of ddr2(5300 i believe)

550 themaltake blackwidow

1tb seasgate @ 7200 rpms

More about : terrible performance 5770

a c 1415 U Graphics card
a b Ý World of Warcraft
July 4, 2010 5:32:50 PM

First of your CPU is holding the GPU back a little. The BFBC2 is a demanding game and at 1920 resolution you would need a more powerful card.
m
0
l
July 4, 2010 5:40:49 PM

well. From every review i've and every benchmark/video i have watched on this card. This card runs a solid 35-60+ at this resolution the frames i get is what most 5770's are getting while fraps is recording. Also.... i benchmarked trackmania nations yesterday and i got a massive 20.1 average fps, I go to youtube and a guy with the hd 5770 is getting 87.1 average what is the heck is that?Something doesn't seem right with my computer but I don't know what it could be. As far as wow goes. I had a gts 250 before this card and it ran like complete Crap. but I just upgraded mobo's 3 days ago cause i thought that was my problem but i don't think it was.....
m
0
l
Related resources
July 4, 2010 5:50:56 PM

Maybe an xfx or evga brand would be better.I can't recognise the manufacture of your card.
m
0
l
a c 273 U Graphics card
July 4, 2010 6:03:22 PM

mariosarmy said:
Maybe an xfx or evga brand would be better.I can't recognise the manufacture of your card.

They've been around for a bit now, I can't say whether they are good or bad though.

http://www.hisdigital.com/
m
0
l
July 4, 2010 6:21:40 PM

your cpu is bottlenecking
m
0
l
July 4, 2010 6:25:12 PM

ok my cpu is bottlenecking. but... Still that wouldn't explain wow. wow really isn't that graphic intense? Do you really think it is solely my cpu? Think there could be some other issues going on? and His is a decent company. I just like there iceq technology and I like the factory over clock..
m
0
l
July 4, 2010 7:12:47 PM

well from knowledge i have gained. I should be running everything max. without issue. But if not. Still doesn't explain a game like wow. or trackmania. They are running so bad it's ridiculous. as i stated in my first post. my average fps for trackmania was 4X lower than someone else with this same card...
m
0
l
a c 126 U Graphics card
July 4, 2010 7:20:12 PM

Here it is again for you...... You CPU is bottlenecking your graphics card, simple as that.

It doesn't matter if the game your playing isn't very graphically demanding, your CPU is still bottlenecking the GPU.
m
0
l
July 4, 2010 8:35:54 PM

alright then... well do you think an overclock on it until i can muster up some mula for a better one would do me any amount of good?
m
0
l
a c 126 U Graphics card
July 4, 2010 8:42:15 PM

it would certainly help.
m
0
l
July 4, 2010 9:40:53 PM

It must be your resolution like the people here said.

I play BFBC2 at 1680 X 1050 (my monitors native resolution) on high settings and get an avg. of ~ 45 FPS (sometimes higher).

I have a similar set up to you:

-Gigabyte ATi Radeon HD 5770 (GV R577UD-1GD)

-Intel Core 2 Quad Q6600 @ stock 2.4 Ghz

-Gigabyte: G31M-ES2l Motherboard :( 

-4 GB of Transcend DDR2 800 (in actuality its less because I an using windows 7 32 bit so about ~3.25 GB usable)

-SeaSonic M12II 620 W

-WD Blue Caviar 600 GB @ 7200 RPM

Try a lower resolution and let us know what you get?
m
0
l
July 4, 2010 10:01:08 PM

I know that WoW is a pretty CPU intensive game especially in cities. I've got a 9500 phenom and I run about the same as you even with an old 8800gt. I dont know about overclocking these old phenoms though, I've heard they run pretty hot as is.
m
0
l
July 4, 2010 10:07:51 PM

well the only thing that makes me question the quad performance is- I gave my friend my old gts 250 and his computer is just an hp media desktop. 300 watt power supply(i know it's not sufficient for a gts 250) and a dual core cpu. i put his setting to ultra when i put that card in and In towns... He runs 50 frames at 1920 X 1080 and this is with shadows up as well.
m
0
l
a c 232 U Graphics card
a b Ý World of Warcraft
July 5, 2010 4:51:31 AM

I hate to ask, but did you uninstall the Nvidia drivers completely (and follow up with a registry cleaner like CCleaner) before you installed the ATI drivers? What version of ATI CCC/Catalyst Suite are you running? Current version is 10.6 and you should be running it.

Regardless of the perceived bottleneck, this system should be performing better than what you described.
m
0
l
July 5, 2010 4:54:31 AM

this is a fresh copy of windows as of yesterday. So no there is no Nvidia software period on my computer. and I'm using 10.4 because i down graded. I've been Going back and forth seeing which works best. Sometimes the latest drivers aren't always the best. But yeah i agree with you even with a bottleneck i should be seeing better than what i am getting. Maybe my processor is just that crappy even though is a quad core. I don't know...?
m
0
l
a c 232 U Graphics card
a b Ý World of Warcraft
July 5, 2010 5:19:29 AM

While the Phenom 9600 isn't cutting edge it is no slouch either and should not be the bottleneck some have indicated. I am using 10.6 and have had no issues with any games or apps and performance has been great.

Lets get back to your system. Are you using AMD NB/SB drivers or the default set of chipset drivers from MS? Are you OCing anything (CPU or GPU)? Do you have 2x512 and 2x1024 DIMMs installed or 1x1024 and 1x2048 DIMMs or 3x1024 DIMMs? Are you running single or dual channel mode with your memory?

Another thing you can do to isolate whether the GPU is flaky is to remove it and use the on-board ATI HD4200 GPU (you'll need to re-install ATI CCC but that is no big deal) to see if it chokes or not.

It is possible you have a bad 5770. All of the questions are in the attempt to rule things in or out for consideration.
m
0
l
July 5, 2010 6:06:27 AM

umm well windows 7 installed all the drivers for my mobo on startup. But i did go to the asus website and download the chipset not sure about the nb/sb though Not Techy with Mobo's really =/. and nothing is Oc'd My 5770 is factory overclocked But that is all. and i'm using 3x 1024 dimms. and i think dual channel. not sure though?
m
0
l
July 5, 2010 6:20:57 AM

Grant827 said:
this is a fresh copy of windows as of yesterday. So no there is no Nvidia software period on my computer. and I'm using 10.4 because i down graded. I've been Going back and forth seeing which works best. Sometimes the latest drivers aren't always the best. But yeah i agree with you even with a bottleneck i should be seeing better than what i am getting. Maybe my processor is just that crappy even though is a quad core. I don't know...?



Well like I said I have a 2.4 Ghz quad-core and it works fine at my lower resolution. I am also using CCC 10.4 it gives me the best FPS and temps out of the ones I have tested so far: 10.4, 10.5 & 10.6 .
m
0
l
July 5, 2010 6:25:13 AM

Your mobo is an easy overclocker....pump up your cpu to 3ghz and benchmark
m
0
l
July 5, 2010 7:04:53 AM

really 3ghz? I got a stock cooler... And I'm not too familiar with overclocking. Would it even be stable? is there a program for overclocking cpu?
m
0
l
July 5, 2010 7:16:50 AM

what kind of temps abouts should i be looking for?
m
0
l
July 5, 2010 8:35:35 AM

since we were on the subject of overclocking. I'm using this amd overdrive software. I did a benchmark and I have a lousy 4700 score.
m
0
l
a c 232 U Graphics card
a b Ý World of Warcraft
July 5, 2010 2:40:50 PM

If you have 3x1024 DIMMs you are in single channel mode. For dual channel you matched DIMMs in the proper slots in your mobo. This is definitely a bottleneck in performance. If you go to ati.com you can download current chipset drivers. That too will help.
m
0
l
July 5, 2010 3:35:12 PM

hmmm well How exactlly do i get it in dual channel mode then o.O
m
0
l
July 5, 2010 3:38:11 PM

and I just downloaded cpu-z and it says my ram is in Dual-channel mode..
m
0
l
a c 232 U Graphics card
a b Ý World of Warcraft
July 5, 2010 4:29:53 PM

What does it say about you memory configuration (number and type of DIMMs)?

BTW, that is good that it is in dual mode. That means that you have matched DIMMs. Setting dual mode is usually automatic if the mobo detects memory that can support it.

How about the drivers?
m
0
l
July 6, 2010 10:41:24 PM

well. It is pc5400 666 mhz it says 334.8 mhz but i know your suppose to double it or whatever. and which drivers ya talking about?
m
0
l
July 6, 2010 10:42:33 PM

one thing about this performance issue as well. I was playing BFBC2 and opened up Gpu-z and it said my card was only usuiong 41% of it's gpu. So it really wasn't working that hard so i'm guessing Like others said processor bottleneck...
m
0
l
July 7, 2010 1:37:15 AM

Yeah i just installed that even though i'm pretty sure they were all up to date. Um It didn't change anything thanks though. I'm ram'ing my quad tomorrow I think it is my processor I've pretty much tried everything. power supply, new mobo/graphics card, Put in my friends 8 gigs of ram in my comp, new 1 tb HD, even when i put in my dual core. It showed a significant performance increase on some older games. So maybe my quad is just defective.
m
0
l
a c 232 U Graphics card
a b Ý World of Warcraft
July 7, 2010 1:51:40 AM

It is certainly possible. Hope the new CPU does the trick. Please inform the collective when you have the new CPU up and running and let us know if it made a difference. HOOAH!!!
m
0
l
July 7, 2010 4:32:45 AM

ok man. Sincerely thank you for the tips and help i really do appreciate it man! and too all that did =]]
m
0
l
!