Sign in with
Sign up | Sign in
Your question

Problems with Xfx HD 5850

Last response: in Graphics & Displays
Share
July 5, 2010 11:32:00 AM

Hello guys,

I built this pc a couple of days ago and I wanted to test it with 3dMark Vantage but the program keeps crashing after the second test (it crashes at te airplane test). In the first 5 seconds it runs and than I just get a static grey screen. After this I am still able to go to the desktop but there all the icons have turned pixelly and their colours are weird too (purpleish). Most of my running programs crash too at this time. I get the same issues when I try to run Aliens versus Predator. It goes on a couple of minutes and then the graphical interface crashes accompanied by weird noises from my spekers. The cpu runs at a temperature of max 55 degrees celsius when working and the videocard at 45 when idle. By now I didn't look at it's temperature when gaming but I don't think it would be a heat problem. I havn’t tested the system yet with other programs. I do not overclock. I lowered only the cpu voltage because my stock cooler isn't the best. Thanks for the help.

My specs are:

Amd Phenom II X4 955
XfX HD 5850
Asrock 870 Extreme 3
Cooler Master GX RS-750-ACAA-E3
Kingston ValueRAM 4 GB : 2 x 2 GB - DIMM 240-pins - DDR3 - 1333 MHz / PC3-10600 - CL9 - 1.5 V -

More about : problems xfx 5850

July 5, 2010 1:38:02 PM

What Catalyst version are you using?
I run an XFX 5850 CC 10.4 no problems.
It could also be a ram issue.
Have you Memtested your ram?
July 5, 2010 2:14:08 PM

Lowering your CPU voltage can cause stability problems.
At the same time, the airplane physics test is very stressful on CPUs.

You should look into that.
!