Sign in with
Sign up | Sign in
Your question

Further 5870 Issues (?)

Last response: in Graphics & Displays
Share
July 5, 2010 6:32:02 PM

I am back once again with further problems with my 5870, possibly. I RMA'd the last card and now have the new one. It installed fine and I updated the drivers immediately. My new problem is unique, however. Whenever I start a game such as World of Warcraft, Mass Effect 2, Crysis, etc. the the screen becomes a series of bars. Either black and purple bars, or black and green bars, depending the game I'm playing. I cannot alt+tab out of it and I can't access the task manager. Basically it cripples me and forces me to do a manual restart. That being the problem I think it could also be a problem with the monitor. I turned on my sound for another attempt and noticed that when it locked up my computer again the game sound stayed on even when I had alt+tabbed or started the task manager.

Anyone have any similar problems? Or could someone identify for me what is causing this?

Computer Components:
OS: Windows 7 64 bit
Video Card: Radeon HD 5870 Eyefinity Edition
Motherboard: ASUS P55
PSU: Corsair 750TX
RAM: G.Skillz 4GB 1600MHz
CPU: Intel core i5

Basic Driver/Support Info


If you guys want a picture of my video card inside the case to see if I installed it manually correctly that shouldn't be a problem either!

Thanks!

More about : 5870 issues

a b U Graphics card
July 5, 2010 7:20:39 PM

Do you have an older PCI-E graphics card you can install just to try to rule out the video card? It seems like a GPU problem. But there could be issues with lack of power from the PSU, or even a problem through the motherboard.

How about any OverClock on the processor or RAM? If they are OC'd, you might want to return them to default settings and reboot. Then see if the problem remains. If it does, then it may very well be a GPU issue again.
a b U Graphics card
July 5, 2010 8:40:16 PM

Sounds like a driver issue, did you remove ALL previous driver related files prior to installing the GPU?
Related resources
a b U Graphics card
July 5, 2010 8:45:08 PM

OvrClkr said:
Sounds like a driver issue, did you remove ALL previous driver related files prior to installing the GPU?


Uninstall all your graphics/driver files (ATI & nVidia) and use this:

Driver Sweeper
http://www.guru3d.com/category/driversweeper/

Then reinstall any necessary drivers. Keep in mind, if you have a motherboard which uses nVidia chipsets, you don't need to remove those. Just graphics drivers.
July 6, 2010 12:55:23 AM

I uninstalled all the drivers using the function given me by the ATI catalyst control center. I then ran the driver sweep in safe mode and eliminated all the drivers under the ATI category. I then rebooted and installed the latest and greatest for my card. Here's the link in case I messed up: http://game.amd.com/us-en/drivers_catalyst.aspx?p=win7/.... I then rebooted and started up World of Warcraft and it turned into a series of bars that matched the color of the UI. The same happened for Crysis.

Any other suggestions?

Thanks for the effort!
July 6, 2010 1:34:51 AM

Another interesting side note, occasionally I can get into World of Warcraft, run around for a bit, and then the bars will appear. I mess with my bar addons, save a profile of it, and then the next time I am able to log in after it crashes, the profile no longer exists and my bars are reset to the default that the addon starts with.

Just an interesting little fact.
a b U Graphics card
July 6, 2010 5:15:43 AM

From what vendor is your 5870?
!