Sign in with
Sign up | Sign in
Your question

No Display No Boot wid wokin Smps n Mobo

Last response: in CPUs
Share
October 22, 2010 6:20:45 AM

Hello,
Hello,

I recently left my system on for whole night, and wen i woke up in d morning, the system ws dead. troubleshot SMPS and found that it ws gone, so i replaced it with the new one, first i was not sure about the exact conenctions of smps to mobo, but still i bleev i did a gud research to put all the wire into the place except HDD LED,Power SW and POwer Reset cable coming from front panel. So at first, the CPU fan wasnt working and the system was still dead, so i did more experimentation and now the CPU fan on mobo is running and front panel Power LED is lit but nt bright as earlier, and the CPU fan is running only wen i do smthing pretty strange i.e. 24 pin cable is nt completely (tightly) inserted into mobo but bit loose. And system is starting as soon as i switch on the wall power outlet and no matter for how long i press the power button nothing is happening, fans keep on spinning. I even tried connectin my monitor, but no display......monitor LED starts to blink but no display. Dont know what to do..........please help guys!!!

Mobo: Mercury P1945GCM

RAM: DDR2 2gb. ( no beeps are coming without RAM too :(  )

HDD: 80 gb.

Proc: Intel Dual Core 2 GHz.
a c 172 à CPUs
October 22, 2010 6:36:54 AM

Mercury motherboards are pretty cheap motherboards.

Work through our standard checklist and troubleshooting thread:
http://www.tomshardware.com/forum/261145-31-read-postin...
I mean work through, not just read over it. We spent a lot of time on this. It should find most of the problems.

If not, continue.

I have tested the following beep patterns on Gigabyte, eVGA, and ECS motherboards. Other BIOS' may be different.

Breadboard - that will help isolate any kind of case problem you might have.
http://www.tomshardware.com/forum/262730-31-breadboardi...

Breadboard with just motherboard, CPU & HSF, case speaker, and PSU.

Make sure you plug the CPU power cable in. The system will not boot without it.

I always breadboard a new build. It takes only a few minutes, and you know you are putting good parts in the case once you are finished.

You can turn on the PC by momentarily shorting the two pins that the case power switch goes to. You should hear a series of long, single beeps indicating memory problems. Silence indicates a problem with (in most likely order) the PSU, motherboard, or CPU. Remember, at this time, you do not have a graphics card installed so the load on your PSU will be reduced.

If no beeps:
Running fans and drives and motherboard LED's do not necessarily indicate a good PSU. In the absence of a single short beep, they also do not indicate that the system is booting.

At this point, you can sort of check the PSU. Try to borrow a known good PSU of around 550 - 600 watts. That will power just about any system with a single GPU. If you cannot do that, use a DMM to measure the voltages. Measure between the colored wires and either chassis ground or the black wires. Yellow wires should be 12 volts. Red wires: +5 volts, orange wires: +3.3 volts, blue wire : -12 volts, violet wire: 5 volts always on. Tolerances are +/- 5% except for the -12 volts which is +/- 10%.

The gray wire is really important. It should go from 0 to +5 volts when you turn the PSU on with the case switch. CPU needs this signal to boot.

You can turn on the PSU by completely disconnecting the PSU and using a paperclip or jumper wire to short the green wire to one of the neighboring black wires.
http://www.youtube.com/watch?v=5FWXgQSokF4&feature=yout...

A way that might be easier is to use the main power plug. Working from the back of the plug where the wires come out, use a bare paperclip to short between the green wire and one of the neighboring black wires. That will do the same thing with an installed PSU. It is also an easy way to bypass a questionable case power switch.

This checks the PSU under no load conditions, so it is not completely reliable. But if it can not pass this, it is dead. Then repeat the checks with the PSU plugged into the computer to put a load on the PSU.

If the system beeps:
If it looks like the PSU is good, install a memory stick. Boot. Beep pattern should change to one long and several short beeps indicating a missing graphics card.

Silence or long single beeps indicate a problem with the memory.

Insert the video card and connect any necessary PCIe power connectors. Boot. At this point, the system should POST successfully (a single short beep). Notice that you do not need keyboard, mouse, monitor, or drives to successfully POST.
At this point, if the system doesn't work, it's either the video card or an inadequate PSU. Or rarely - the motherboard's PCIe interface.

Now start connecting the rest of the devices starting with the monitor, then keyboard and mouse, then the rest of the devices, testing after each step. It's possible that you can pass the POST with a defective video card. The POST routines can only check the video interface. It cannot check the internal parts of the video card.
m
0
l
!